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Patent Notices
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48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the department of Defense,
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1
Welcome to SolidWorks 2014

This chapter includes the following topics:

• Highlights
• Top Enhancements
• For More Information

Highlights
SolidWorks® 2014 includes many enhancements and improvements, most in direct
response to customer requests. This release focuses on the following themes:

• Focused design tools: Powerful
new features and time-saving
shortcuts deliver greater
productivity.

• Integrated workflows:
Streamlined processes and
information sharing remove the
barriers to innovative design.

• Increased performance: Faster
system response and reduced user
interaction help you maintain design
focus.

• Enhanced visualization: Stunning
graphics and improved visualization
tools create a more powerful
collaborative environment.

Top Enhancements
The top enhancements for SolidWorks 2014 provide improvements to existing products
and innovative new functionality.

Throughout this guide, look for the symbol in these areas:
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• Applying Standard Mates from a Context Toolbar on page
16

• Selecting Items by Lasso on page 19

User Interface

• Browsing Recent Documents [Project 18899]
• Configurable Equations on page 24
• Selecting Bodies or Components for Section Views on
page 29

• Solar Access Studies on page 36

SolidWorks
Fundamentals

• Applying Standard Mates from a Context Toolbar on page
16

• Creating Slot Mates on page 56
• Including Rotations in Exploded Views on page 53
• Spherical and Curvilinear Mates on page 60

Assemblies

• Creating a Limited-access Costing Template on page 81
• Simplifying Cost Estimates on page 85
• Volume Features on page 94

SolidWorks
Costing

• Angular Running Dimensions on page 103
• Out-of-Date Drawing Views on page 119
• Replace Model for Drawing Views on page 119
• Section View of a Surface on page 124
• Sheet Formats on page 133

Drawings and
Detailing

• Automated Cache Management on page 139
• Navigating Tree Structures on page 146
• User Defined Custom Columns on page 146
• Version Comparison of Referenced Files on page 147

SolidWorks
Enterprise PDM

• Conic Fillets on page 152
• More Options for Deleting Features on page 155

Parts and Features

• Bent Lofted Bends on page 166Sheet Metal

• Replace Sketch Entities on page 187
• Setting a Fixed Length on page 190
• Style Splines on page 190

Sketching
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• Automatic Conversion of Toolbox Fasteners to Bolts on
page 174

• Contact Visualization Plot on page 178
• Importing Results from SolidWorks Plastics on page 182

SolidWorks
Simulation

All features are available in SolidWorks Standard, SolidWorks Professional, and SolidWorks
Premium unless otherwise noted.

For More Information
Use the following resources to learn about SolidWorks:

This guide is available in PDF and HTML formats. Click:

• Help > What's New > PDF
• Help > What's New > HTML

What's New in PDF
and HTML

In SolidWorks, click the symbol to display the section of this
manual that describes an enhancement. The symbol appears
next to new menu items and the titles of new and changed
PropertyManagers.

To enable Interactive What's New, click Help > What's New
> Interactive.

Interactive What's
New

What's New Examples are updated at every major release to
provide examples of how to use most top enhancements in the
release.

To open What's New Examples click Help > What's New >
What's New Examples.

What's New
Examples

Contains complete coverage of our products, including details
about the user interface, samples, and examples.

Online Help

Provides information about late changes to our products.Release Notes

14

Welcome to SolidWorks 2014



2
User Interface

This chapter includes the following topics:

• Accessibility
• Applying Standard Mates from a Context Toolbar
• FeatureManager Design Tree Response to Selections
• Including SmartMates in the CommandManager
• Selecting Items by Lasso
• Sticky Settings
• Text and Button Sizes

Accessibility
An updated color scheme for certain icons makes the SolidWorks application more
accessible to people with color blindness. Also, provides a more readable font.

Icons in the active PropertyManager use blue to indicate what you must select on the
screen; faces, edges, and so on. Adding blue to the icons provides a sharp contrast in
colors so that many SolidWorks users with color blindness can distinguish one icon from
another.

Along with style updates to the main elements of the SolidWorks user interface, there is
a more readable font. Turn on ClearType®, software technology developed by Microsoft®,
to make the text on your screen easier to read.

SolidWorks 2014SolidWorks 2013
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Turning on ClearType

To turn on ClearType:

1. From the Windows Start menu, click Control Panel.
2. Click Appearance and Personalization.
3. Click Display, and on the left, click Adjust ClearType text.
4. Select Turn on ClearType, click Next, and complete the wizard.

The text on your screen uses the new, easier to read SolidWorks font.

Applying Standard Mates from a Context Toolbar
You can apply standard mates in an assembly from a context toolbar.

The toolbar appears when you press CTRL + select mating geometry in the graphics
area. Only mates that are appropriate for your selections are available.

1. From an assembly, press CTRL + select entities to mate.
The default mate is highlighted in the context toolbar.

2. Select a mate.

3. For distance or angle mates, enter the mate specification and click .
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FeatureManager Design Tree Response to Selections
When you select an item in the graphics area, the FeatureManager® design tree expands
and scrolls to the selected item. Clicking in the graphics area without selecting an item
restores the scroll state of the FeatureManager design tree.

After SelectionBefore Selection
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After SelectionBefore Selection
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This behavior is on by default. To turn this behavior off, click Tools > Options, select
FeatureManager, and clear Scroll selected item into view.

Including SmartMates in the CommandManager
You can include the SmartMates command when customizing the Assembly toolbar or
the Assembly CommandManager.

To include the SmartMates command in the CommandManager:

1. Open an assembly.
2. Click Tools > Customize, or right-click the CommandManager and select Customize.
3. On the Commands tab, select Assembly.

4. Drag the SmartMates command to the Assembly CommandManager, and click
OK.

Selecting Items by Lasso
You can select items in the graphics area with a lasso.

You can lasso-select items in sketches, drawings, parts, and assemblies.

To lasso-select items in an open document:

1. Set the default selection method to lasso selection by one of the following methods:

• In the graphics area, right-click and click Lasso Selection.

The software toggles the default selection method between lasso selection and
box selection. If Box Selection, rather than Lasso Selection is available when
you right-click, then your default selection method is already set to lasso
selection.

• Click Tools > Lasso Selection.

• Click Tools > Options or Options (Standard toolbar). Select
Display/Selection, and for Default bulk selection method, select Lasso.

2. Drag your pointer to select items.

You can lasso-select items without closing the lasso.

For clockwise lasso selection, the lasso selects only items contained in the lasso
loop. For counterclockwise lasso selection, the lasso selects sketch entities in the
lasso loop and items that cross the lasso.
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The software supports counterclockwise lasso selection only in drawings or sketches.

3. Release the mouse button.

Sticky Settings
Settings in certain options persist across SolidWorks sessions and versions until you
change them.

Settings in certain options persist after you click OK or when you accept PropertyManager
options.

The following options persist across SolidWorks sessions and versions:

When you click Gap Control and type custom values for the
Gap Control dialog box, the Gap Control check box and the
values you enter persist.

Knit Surface
PropertyManager

The new settings under Flange Length and under Flange
Position and the values that you enter persist.

Edge Flange
PropertyManager

20

User Interface



The settings under End Condition and the Depth values that
you enter persist.

Hole Specification
PropertyManager (Hole
Wizard)

Text and Button Sizes
You can set sizes for text and buttons from the Toolbars tab of the Customize dialog box.

• Text in menus, tree items, dialog boxes, and PropertyManagers respects your SolidWorks
software or operating system text size selection.

• You can set button sizes independent of the text size.
• The larger button sizes facilitate running the SolidWorks software on machines with
high resolution displays.

• For low resolution displays, dialog boxes are automatically resized when they do not
fit on the screen, and scrollbars appear automatically.

• To facilitate element selection on touch interfaces such as tablets, you can set up the
larger size buttons and text from the Options menu (Standard toolbar).

To view the text and button settings, click Tools > Customize, and in the dialog box,
select the Toolbars tab.
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3
SolidWorks Fundamentals

This chapter includes the following topics:

• Accessing Recent Features Through History
• Application Programming Interface
• Equations
• Dismissing All Prompts for Missing Components
• Graphics
• Updating Assembly Graphics
• Opening Document Copies
• Pack and Go Toolbox Option
• Recent Documents
• Version Support for DXF and DWG Files
• Saving SolidWorks Files as Portable Network Graphics Files

Accessing Recent Features Through History
From the History folder at the top of the FeatureManager design tree, you can access
the features that you have most recently created or edited. You can also control the
number of features to list in the History folder.

To access recent history:

• In the FeatureManager design tree, expand the History folder.

Setting History Length
You can set the number of edited features listed in the History folder.

To set the history length:

1. From an open document, in the FeatureManager design tree, right-click the History
folder and click History Options.

2. In the PropertyManager, under History Length, for Maximum, type an integer
between 1 and 99.
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Application Programming Interface
See SolidWorks 2014 API Help Release Notes for late-breaking updates.

SolidWorks 2014 includes the ability to:

• Access mirror part feature data.
• Access flat-pattern folders in the FeatureManager design tree.
• Access sheet metal folders in the FeatureManager design tree.
• Access Fill Pattern feature data.
• Insert a Variable Pattern feature in the FeatureManager design tree.
• Create a new part document that mirrors another part document about a selected
reference plane or planar face.

• Select assembly components by percent of assembly size.
• Get better error reporting when getting, setting, adding, or deleting custom properties.
• Attach an existing annotation to a drawing sheet or view.
• Replace the model in selected drawing views.
• Get library feature reference names.
• Get and set whether a part is a SolidWorks Toolbox part.
• Get a return code after rebuilding an assembly or drawing.
• Get and set the property values for a sunlight source.
• Access SolidWorks CommandManager tabs:

• Get all of the tab names.
• Get and set the visibility of tabs.
• Get and set the active tab.
• Get and set the index of tabs.
• Send notification when a tab is about to be activated for:

• Assembly document.
• Drawing document.
• Part document.

• Get and set whether to generate a graphics-only section view.
• Get and set whether to override default sheet metal feature parameters.
• Get and set whether to use a sheet metal feature gauge table.
• Get the actual entities associated with a sketch relation.
• Save various aspects of a part (sheet metal, faces, loops, and annotation views) to one
or more DXF/DWG files, preserving the specified filename.

• Get and set the text format and font size of callouts.
• Change standard model views and reset them to their default settings.
• Get all visible entities, including silhouette edges, in drawing views.
• Send notification when a document is printed.
• Get the persistent ID of:

• Component.
• Feature.

• Change dimension tolerance values in specific configurations in a multi-configuration
part or assembly.

• Derive the hole series feature data interface from IDispatch instead of IUnknown.
• Insert general table annotations in part and assembly documents.
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Equations

Configurable Equations
The ability to apply configurations to equations and global variables is enhanced. You can
configure equations and global variables in the same way as you configure dimensions.

Previously, you could only configure equations and global variables by suppressing or
unsuppressing them in selected configurations.

Now you can create variations of equations and global variables, and apply them to
configurations using the Equations and Modify dialog boxes. You can also configure
equations and global variables in design tables, and in various PropertyManagers for parts
and assembly features.

For example, when you create an equation in the Distance field of the Chamfer

PropertyManager, you apply configurations to it by using the configuration icon that
displays in the field. You can then edit the equation and assign it to different configurations
using the Equation or Modify dialog boxes.

You can also specify a different unit of measurement for each configuration. For example,
you can have one configuration where a global variable is expressed in millimeters and
another where it is expressed in inches.

In a design table, equations must be preceded by a single apostrophe and an equal
sign ('=). The single apostrophe ensures, that if the equation is exported to Excel, it
is interpreted as an equation and not as a text string.

You cannot use configurable equations and suppression/unsuppression in the same model.
If you created a model with SolidWorks 2013 or an earlier version, you must remove all
suppressed and unsuppressed equations and global variables, before adding configurable
equations and global variables. You must also remove design tables, then save and
re-open the document file with SolidWorks 2014.

Sketch View
A Sketch View is available in the Equations, Global Variables and Dimensions dialog box.

With this view, you can add, rename, edit, configure, and delete equations, global
variables, and dimensions used in sketches.

Dismissing All Prompts for Missing Components
You can dismiss all prompts for missing components for the document you are opening.

Select Suppress all missing components in the Unable to locate file dialog box that
appears when a document cannot locate a referenced file.

This option affects only the current document. This option does not permanently dismiss
all Unable to locate file dialog boxes for all documents.
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Graphics

Accurate Environment Lighting
You can apply accurate environment lighting to clean up excessive noise in renderings.

The benefits of using accurate environment lighting are:

• Accurate environment lighting calculation from custom high dynamic range images,
HDRI, used for scene environments.

Use accurate environment light when:

• Shadows in the current rendering are too noisy.
• You use a custom HDRI image to define the scene and you need more accurate lighting
from the custom HDRI image.

Apply the accurate environment lighting when you refine renderings using the PhotoView
360 preview window.

When you use this setting, it can significantly slow down rendering.

To apply accurate environment lighting:

1. With a model open, click Tools > Add-Ins and add in PhotoView 360.

2. From the DisplayManager, click View Scene, Lights, and Cameras .
3. Right-click Scene and select Edit Scene.

To view the document scene you must set the background appearance to Use
document scene. Click Yes to set the background appearance, if the Background
Display Setting dialog box appears.

4. On the Illumination tab, under PhotoView Illumination , select Accurate
environment lighting.

5. Click .

With accurate environment lightingWithout accurate environment
lighting

25

SolidWorks Fundamentals



Refining Renderings
You can save renderings in progress directly from the PhotoView 360 Preview window.

You can use the extended refinement settings in the PhotoView 360 Preview window to
refine the rendering beyond the specified quality setting in the PhotoView options. The
quality of the rendering increases over time. You can also specify that the PhotoView 360
Preview window create an image that uses the full specified output image size in the
PhotoView options.

Use continuous refinement with the Accurate environment lighting option to get
the best results.

To refine renderings:

1. Click PhotoView 360 > Preview Window.
2. Choose how you want to do the rendering:

• Extended refinement to force the preview to refine beyond the specified quality
settings in PhotoView options.

• Full resolution preview to force the preview to render an image that is saved
at the size specified in PhotoView options.

3. Click Save Preview Image to save the result displayed in the PhotoView Preview
window at any time.

Creating Graphics-only Section Views
You can quickly generate a section view by generating a graphics-only section view.

To create a graphics-only section view:

1. Open a part or assembly.

2. On the View toolbar, click Section View .
3. Under Section 1, select Graphics-only section.

4. Set other options and click .

You cannot select a sectioned face or edge. You must retain the section cap color in a
graphics-only section view. Pixels that lay within the same plane as the section plane
or face are not hidden.

Exporting SolidWorks Models to *.lxo Files
You can export SolidWorks models, including models with motion studies, to *.lxo files.
You can then import the *.lxo files into MODO®, the rendering product created by Luxology
LLC.

To export a SolidWorks model:

Click File > Save as. In Save as type, select Luxology (*.lxo).
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To export a SolidWorks model and the information from a motion study:

Click Save Animation (MotionManager toolbar). In Save as type, select Luxology
(*.lxo).

Flattened Floors in Scenes
You can flatten the floor of a spherical environment in scenes to improve the look of
models that naturally rest on the ground or flat floors, particularly when performing view
manipulations such as rotate or zoom.

If the model is too large or too small relative to something in the environment, you can
adjust the environment size and scale the environment relative to the size of the model.

You can adjust the horizon height, essentially, from the equator down to the South pole.
Imagine if the HDRI sphere scene is on the ocean. If you position the camera at a height,
such that the horizon is in the middle of the image, then you can adjust the horizon height
to line up with the horizon line. In this case, the gum drop is, essentially, a hemisphere.

If you position the camera very high from the surface of the ocean, then the horizon is
toward the bottom of the image and you can adjust the horizon height to line up with the
horizon line. In this case, the gum drop is like a sphere with a flat surface on one side
that lines up with the floor.

To flatten floors in scenes:

1. From the DisplayManager, click View Scene, Lights, and Cameras .
2. Right-click Scene and select Edit Scene.
3. Under Background, select Use Environment.

You must select Use Environment to use the flatten floor option.

4. Under Floor, click Flatten floor.
5. Set the Environment size to specify the size of the HDRI scene sphere, the gum

drop, that surrounds the model.
6. Set the Horizon Height to specify at what lattitude on the HDRI scene sphere the

floor starts to flatten.

7. Click .

The Flatten floor option works best for environments that have a natural horizon
line near the equator of the spherical environment image. These tend to be exterior
environments. The Presentation Scenes folder now includes 10 new scenes which
work well with the flatten ground control.

Performance Improvements to Rendered Animations
PhotoView 360 saves rendered animations to *.lxo files which contain all the data: the
appearances, scenes, model geometry, and motion study definitions needed to process
rendered animations. Internal conversion to *.lxo files dramatically reduces the time
required to process a rendered animation.

In previous versions of the SolidWorks software, for each frame of a motion study, the
SolidWorks MotionManager solves the motion and saves the model at that frame.
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PhotoView 360 then loads the model and renders the model for each frame. For example,
if you have a one second animation at 30 frames per second (FPS), the SolidWorks
software saves a model 30 times and PhotoView 360 loads it and renders the model 30
times. Saving each frame and loading it into PhotoView 360 takes a significant amount
of time.

With the performance improvements to rendered animations, because the SolidWorks
software saves the motion study information in *.lxo files, when PhotoView 360 loads
the model the first time, Photoview 360 has all the information about the entire motion
study model to render it. In the example of a one second animation at 30 FPS, SolidWorks
saves the model just once and PhotoView 360 loads the files once to render all the frames
of the animation.
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Selecting Bodies or Components for Section Views
You can select bodies or components to include in or exclude from section views.

To select bodies or components for section views:

1. Open install_dir\samples\whatsnew\fundamentals\jig saw\Jigsaw.SLDASM.

2. Click Section View (View toolbar) or View > Display > Section View.

29

SolidWorks Fundamentals



30

SolidWorks Fundamentals



3. In the PropertyManager, under Section 1, click Side .

4. Click Selected components.
5. In the flyout FeatureManager design tree, select these items to add them to Selected

components.

• MOTOR DRIVE
• SW0903A GEAR DRIVE
• SW0903A CAM
• NEEDLE ROLLER (NIH)
• GEAR DRIVE SHAFT
• SW0904 - PLUNGER ASSEMBLY

6. Under Selected components, select Exclude selected.

The selected components appear in their entirety and all other parts appear as
sectioned.
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7. Click Preview to show the graphics-only preview of the section based on the section
plane location and the components or bodies that you select.
Preview hides the section plane, reference plane and face outlines, and the selection
plane.
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8. Select Enable selection plane to display a temporary plane that helps you select
components that are not visible in the model or in the sectioned area.
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9. Drag the center ball of the triad to the right to view hidden components.
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10. In the graphics area, click BEZEL - RIGHT to add it to the Selected components.

11. Click Preview.

12. Click .

To edit the section view, right-click in the graphics area and select Section View
Properties.

Solar Access Studies
With SolidWorks Professional, you can apply sunlight to SolidWorks models. Using solar
access studies, you can simulate the movement of the sun as it passes over models of
buildings, solar panels, and outdoor equipment.

You must include the following data when specifying sunlight for a model:

• The direction of north with respect to the model
• The geographic location of the model
• The time and date to simulate

You can create two types of solar access studies:
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Displays the path of the sun on a specific date across
a range of time.

Fixed date, variable time

Displays the position of the sun at a specific time of
day across a range of dates.

Fixed time, variable date

Adding Sunlight to a Model
The sunlight you add to a model takes location, time, date, and atmospheric conditions
into account.

To add sunlight to a model:

1. From a part or assembly, click View > Lighting and Cameras > Add Sunlight.
2. In the PropertyManager, for Location, Time, and Date, specify the options:

a) For North direction, select a planar face or an edge.
The north direction is perpendicular to a selected face, or collinear with a selected
edge.

Click Flip direction to change the direction from which the sun is applied to
the model.

b) For Location, select a location from the list, or click Specify Location and enter
values for North latitude and East longitude.

c) Enter values for the time:

Specifies the time zone for the sunlight location
relative to Greenwich Mean Time.

Time zone from GMT

Specifies the date to apply the sunlight.Date

Specifies the time to apply the sunlight.Time of day

3. To set advanced settings such as haze, sun diameter, ground albedo, or sky gamma,
click Advanced.

4. Click .
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Creating Solar Access Studies
Using solar access studies, you can simulate how sunlight that is applied to a model
changes over time. To create a solar access study, you must first add sunlight to a model.

To create a solar access study:

1. From a part or assembly, select the Motion Studies tab (lower portion of the graphics
area).

2. Click Animation Wizard (MotionManager toolbar).
3. In the wizard, select Solar Access Study and click Next.
4. Select the solar access study type:

DescriptionOption

Displays the movement of the sun over a time range
on a selected date.

Fixed date, variable time

Displays the movement of the sun at a selected time
of day over a range of dates.

Fixed time, variable date

5. Complete the rest of the wizard and click Finish.

6. To run the study, after creating the study, click Play from Start (MotionManager
toolbar).
The speed of the animation depends on your settings. After you play the animation
once, you can drag the timeline to view changes in the shadows as the sun moves.

Solar Access Study Tutorial
In this example, you optimize the placement of solar panels on the roof of a building.

The optimal location for roof-top solar panels is where they receive the most sunlight.
After applying sunlight to a model of a building, you can create a solar access study to
determine the placement of the solar panels. For this example, the building has an HVAC
shed on the roof, which produces shade, and you cannot place the panels on the shed.

You perform the following tasks:

• Open a model of a building with solar panels on the roof.
• Apply sunlight to the model on the winter solstice.
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• Create a fixed date, variable time solar access study.
• View the study results and adjust the solar panel positions to minimize shadows on the
panels.

Opening the Model and Adding Sunlight
First, you open the model of the building and add sunlight.

1. Open install_dir\samples\whatsnew\fundamentals\solar_access\
building_and_solar_panels.SLDASM and save the model as
my_building_and_solar_panels.SLDASM.
The building has an HVAC shed and nine solar panels in arbitrary locations on the
roof.

2. To turn on RealView graphics, click one of the following:

• View Settings > RealView Graphics

• RealView Graphics (View toolbar)
• View > Display > RealView Graphics.

3. To add sunlight, click View > Lights and Cameras > Add Sunlight.

4. Under Location, Time, and Date, for North direction, select the north-pointing
green vector located to the right of the model.
The model includes the north vector as an aid for this example. For North direction,
if you select an edge or line, the north direction is parallel to your selection. If you
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select a planar face, the north direction is normal to your selection. You cannot select
a direction that is normal to the scene floor.

5. If north, N, points the wrong way, click Reverse Direction .
6. For Location, select New York City, NY.

7. For Date, enter 12/21/2013, or the equivalent in your date format, and click .
December 21 is the approximate date of the winter solstice in the northern hemisphere,
the shortest day of the year. By optimizing for solar exposure on the day with the
longest shadows, you can expect to optimize for solar exposure on all days of the
year.

Creating a Solar Access Study
Next, you create a solar access study for the model.

1. Select the Motion Studies tab (lower portion of the graphics area).

2. Click Animation Wizard (MotionManager toolbar).
3. In the wizard, select Solar Access Study and click Next.
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4. On the Select Solar Access Study Type page, select Fixed date, variable time and
click Next.
This type of study displays the movement of the sun over a time range on a selected
date.

5. On the Fixed Date, Variable Time page, select the following and click Next:

• For Select the date, enter 12/21/2013 or the equivalent in your date format.

This is approximately the shortest day of the year at the building location.

• For Select the time range, select Sunrise to sunset.

6. On the Fixed Date, Variable Time page, for Duration (seconds), type 10, and click
Finish.
The duration specifies the duration of the animation you create.

7. Click Play from Start (MotionManager toolbar).
The speed of the animation depends on your settings. After you play the animation
once, you can drag the timeline to view changes in the shadows as the sun moves.

Examining the Shadows
Next, you drag the timeline and examine the shadow exposure.

1. To zoom in on the roof area, click Zoom to Area (View toolbar).
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2. Drag the timeline and inspect the shadow movement throughout the day:

1 sec

2 sec
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3 sec

5 sec
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6 sec

8 sec
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9 sec

The best locations for the panels appear to be south-facing, away from the southwest
corner of the building, and outside of the shadows of other panels and the HVAC.

Adjusting the Solar Panel Positions
Next, you adjust the solar panel positions to minimize the shadows.

1. Select the Model tab.
You move the panels in the Model tab and test the solar study in the Motion Study 1
tab. If you move the panels in the Motion Study 1 tab, the panel position is modified
only in the animation.
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You can click Do no prompt again for this file and click No if prompted to address
missing images.

2. Drag the panels to minimize shadow over the course of the day.

3. Select the Motion Study 1 tab, and click Yes when prompted to update the initial
animation state.

4. Click Play from Start (MotionManager toolbar).
The panel shadow exposure looks very good.

5. Save the model as my_repositioned_building_and_solar_panels.sldasm, and
close the model.

Updating Assembly Graphics
You can set an option to update model graphics data for components when you save
assemblies, to prevent display list data from becoming out-of-date.

To update assembly graphics:

1. Click Options (Standard toolbar) or Tools > Options.
2. On the System Options tab, click Assemblies and select Update model graphics

when saving files.
3. Click OK.
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Opening Document Copies
After opening or modifying a document, you can save it as a copy and open the new copy
automatically. References to the original document are not assigned to the copy.

To copy a document and open the copy:

1. With the document open, click File > Save As.
2. In the dialog box, select Save as copy and open.
3. For File name, type a new name.
4. Set other options and click Save.

Pack and Go Toolbox Option
You can include or exclude referenced Toolbox components when setting up Pack and
Go.

Including Toolbox Components with Pack and Go

To include Toolbox components when you set up Pack and Go:

1. In SolidWorks, click File > Pack and Go.
2. In the dialog box, select Include Toolbox components.
3. Set the other options, and click Save.

Recent Documents
You can use the Recent Documents dialog box to open files with the same controls
contained in the File Open dialog box.

You can also drag and drop a recent document into:

• An open part to create a derived part.
• An assembly to insert the component.
• A drawing to create a view of the model.
• An empty graphics area to open the file.
• Windows Explorer to copy the file to that location.
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Browsing Recent Documents

To open a file from the Recent Documents dialog box:

1. Click File > Browse Recent Documents or press R to display the Recent Document
browser.

2. Hover over a document, click Expand to set any of the options in the File Open
dialog box, and click Open or Open Read-only to open the document.

3. Drag and drop a recent document tile into:

• An open part to create a derived part.
• An assembly to insert the component.
• A drawing to create a view of the model.
• An empty graphics area to open the file.
• Windows Explorer to copy the file to that location.

To close the browser without opening a document, click outside the browser or press
Esc.

Version Support for DXF and DWG Files
You can import and export DXF and DWG files in AutoCAD® 2013 format.

Saving SolidWorks Files as Portable Network Graphics Files
You can save SolidWorks files as *.png files.

To save SolidWorks files as Portable Network Graphics files:
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1. Click File > Save as.
2. In Save as type, select Portable Network Graphics (*.png).
3. Optionally, for Description, type the text that describes your file.
4. Optionally, click View PNG after saving.
5. Optionally, click Options to select output options, and do the following:

a) Select TIF/PSD/JPG/PNG.
b) Under Output as, select Image type, Remove Background, and other options.
c) Under Print capture options, set DPI, and Paper size.
d) Click OK.

6. Click Save.
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4
Installation

This chapter includes the following topics:

• Installing SolidWorks Electrical
• Support for Environment Variables in the Option Editor

Installing SolidWorks Electrical
SolidWorks Electrical is available from the SolidWorks Installation Manager.

You can choose to install, update, and remove SolidWorks Electrical using the SolidWorks
Installation Manager or from a standalone installation package.

If you use the Installation Manager, you can choose to install:

• the client and server tools on the same computer or on different computers
• only the SolidWorks Electrical server tools

Previously, you could only install SolidWorks Electrical from a separate installation package.

Support for Environment Variables in the Option Editor
You can specify file and folder paths using an environment variable in the Administrative
Image Option Editor.

All dialog boxes, that prompt for a file or folder path, include an option where you can
assign a selected folder to an environment variable.

For example, if you select C:\Program Files\SolidWorks Corp, the file path is mapped
to %ProgramFiles%\SolidWorks Corp.

The most common variables are %ProgramFiles% and %SystemDrive%.

You cannot convert all paths into environment variables. For example, Z:\SolidWorks
Data cannot be mapped to an appropriate environment variable.
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5
Assemblies

This chapter includes the following topics:

• Creating Shaded Drawing Views With High Quality Edges
• FeatureManager Structure for Large Design Review
• Including Rotations in Exploded Views
• Mates
• Mirroring Asymmetric Components
• Multiple Configuration Updates
• Patterns
• Selecting Components by Size
• Selecting Configurations from the Context Toolbar
• Shortcuts for Suppressing Items in Design Tables
• Toggling Between Flexible and Rigid States
• Updating Assembly Graphics

Creating Shaded Drawing Views With High Quality Edges
You can create shaded drawing views with high quality edges to prevent far side edges
from displaying on the near side face of a model. This type of view is appropriate for
thin-walled models with features, such as walls or ribs, that make contact with the back
face of the model.

Also, when you use the high quality option for shaded drawing views, the edges print
with better quality and you can hide the edges.

51



To create a high quality drawing view with shaded edges:

1. Open install_dir\samples\whatsnew\fundamentals\ThinWallPart.SLDPRT.

2. Click File > Make Drawing from Part.
a) In the Sheet Format/Size dialog box, select A (ANSI) Landscape and click OK.
b) Click Open READ-Only.
c) Click OK.
d) From the View Palette, drag the Isometric view into the drawing.

3. In the PropertyManager, under Display Style, click Shaded With Edges.

Notice that the ribs contacting the back face are visible on the front face.

4. Click High quality.
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The ribs are no longer visible on the front face.

5. Click .

FeatureManager Structure for Large Design Review
When you open a model in Large Design Review, the structure of patterns and assembly
features are easier to view in the FeatureManager design tree.

The re-organization of these items include component and mirrored patterns and assembly
features, such as cuts, holes, fillets, chamfers, well beads, belts, chains, and feature
patterns.

You must save legacy assemblies in SolidWorks version 2014.

Including Rotations in Exploded Views
You can create exploded view steps that rotate a component with or without linear
translation.

To create an exploded view in an assembly, click Insert > Exploded View.

To include a rotation in an exploded view step:

1. With the PropertyManager open, select the components to rotate in the explode step.
The rotation and translation handles appear.
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2. Select a rotational direction handle and rotate to a desired position.

You can include rotation and translation in the same explode step. You can also
edit the explode step translation distance and rotation angle values in the
PropertyManager.

3. To complete the explode step, click Done.
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Viewing an Explode with Rotations
In this example, you open and explode an assembly that includes rotated exploded view
steps. After you open the assembly, you can view the explode step details to see how to
change values.

1. Open install_dir\samples\whatsnew\assemblies\explode_rotate\
usb_flash_drive_explode.SLDASM and save it as
my_usb_flash_drive_explode.SLDASM.

2. In the ConfigurationManager , expand the default configuration.

3. Right-click the exploded view ExplView1 , and click Explode.
Alternatively, to run an animation of the exploded view, you can click Animate
Explode.
The exploded view includes rotation and translation steps.

4. To view the details of the explode steps, right-click the exploded view and click Edit
Feature.
Since Explode Step 3 includes translation and rotation, Explode Distance and
Explode Angle have nonzero values. If you edit the explode step, you can edit these
values.

5. Close the document without saving it.

Mates

Applying Standard Mates from a Context Toolbar
You can apply standard mates in an assembly from a context toolbar.

The toolbar appears when you press CTRL + select mating geometry in the graphics
area. Only mates that are appropriate for your selections are available.
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1. From an assembly, press CTRL + select entities to mate.
The default mate is highlighted in the context toolbar.

2. Select a mate.

3. For distance or angle mates, enter the mate specification and click .

Creating Slot Mates
You can mate bolts to straight or arced slots and you can mate slots to slots. You can
select an axis, cylindrical face, or a slot to create slot mates.

To create a slot mate:

1. Click Mate (Assembly toolbar) or Insert > Mate.

2. In the PropertyManager, expand Mechanical Mates and select Slot .
3. For Mate Selections, select a slot face and the feature to mate to it:
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• The face of another straight or angular slot
• An axis
• A cylindrical face

You can select overlapping features.

4. Select a constraint option:

DescriptionOption

Lets the component move freely in the slot.Free

Centers the component in the slot.Center in Slot

Places the component axis at a specified distance from
the end of the slot.

Distance Along Slot

Places the component axis at a distance specified by
the percentage of the slot length.

Percent Along Slot

To change the endpoint from which the distance is measured, select Flip
dimension.

For slot-to-slot mates, you can select only Free or Center in Slot.

5. Click .

Default Mate Types
When you select cylindrical faces or circular edges to mate with an axis, the software
creates a concentric mate. When you select two parallel planar faces, the software creates
a coincident mate.

Some default mate types have a secondary default mate that is created when the
primary default mate type coincident mate over-defines the assembly. For example,
the software creates a parallel mate between two planar parallel faces when a coincident
mate over-defines the assembly.

To mate an axis with a cylindrical face in an assembly:

57

Assemblies



1. Select an axis and a cylindrical face or circular edge.

To display temporary axes, expand Hide/Show Items (Heads-up View toolbar)

and click View Temporary Axes .

2. Click Mate (Assembly toolbar) or Insert > Mate.
The mate defaults to a cylindrical mate.

3. Complete the mate and click .

Including SmartMates in the CommandManager
You can include the SmartMates command when customizing the Assembly toolbar or
the Assembly CommandManager.

To include the SmartMates command in the CommandManager:

1. Open an assembly.
2. Click Tools > Customize, or right-click the CommandManager and select Customize.
3. On the Commands tab, select Assembly.

4. Drag the SmartMates command to the Assembly CommandManager, and click
OK.

Mirrored Components and Mates
Mirrored components include most advanced and mechanical mate types. In earlier
releases, mirrored components included only mate types defined by two entities.

The following advanced and mechanical mate types are included in the mirror:

• Cam
• Hinge mates
• Linear coupler
• Path mates
• Symmetric mates
• Universal joints
• Width mates
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Pinning the Mate PropertyManager

Clicking in the Mate PropertyManager saves your mate specification and closes the
PropertyManager, unless you pin the PropertyManager open.

To specify more than one mate in the Mate PropertyManager:

1. Specify a mate.

2. In the PropertyManager, click before you click .

3. Specify the next mate and click .
4. Repeat Step 3 until you are done specifying mates.

5. To close the pinned PropertyManager, click .

Preventing Rotation in Concentric Mates
You can prevent the rotation of components that are mated with concentric mates by

selecting the Lock rotation option. Locked concentric mates are indicated by an icon
in the FeatureManager design tree.

You cannot lock concentric mates when a referenced component is over-defined.

To lock a concentric mate in an assembly:

1. Open the Mate PropertyManager for a concentric mate:

• For an existing mate, in the FeatureManager design tree, select the concentric
mate and click Edit Feature .

• For a new mate, click Insert > Mate. Under Standard Mates, select Concentric

and select the components to mate.

2. In the PropertyManager, select Lock rotation and click .

To lock rotation on all concentric mates in an assembly, in the FeatureManager
design tree, right-click the Mates folder and click Lock Concentric Rotation.

Setting the Sensitivity of SmartMates
You can set the speed at which the software applies SmartMates.

To set the SmartMate sensitivity:

1. Click Options (Standard toolbar) or Tools > Options.
2. Select Performance.
3. In Assemblies, for SmartMate sensitivity, drag the slider from left to right to

decrease the speed.
4. Click OK.
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Specifying Limit Mate Values in Design Tables
You can specify the lower and upper limit values for limit mates in design tables.

To specify limit mate values in a design table:

• Define columns for the limit mate and its upper and lower limits:

DescriptionOption

Entering 1 in a cell specifies a limit
mate for the table row.

D1@LimitDistance1

Specifies the upper limit value for the
limit mate.

$UPPERLIMIT_DISTANCE@LimitDistance1

Specifies the lower limit value for the
limit mate.

$LOWERLIMIT_DISTANCE@LimitDistance1

Spherical and Curvilinear Mates
You can create mates using spherical bodies and surfaces.

You can create mates for spherical bodies with the following relationships:

• Tangential to nonlinear edges and sketches
• Tangent to nonplanar surfaces

You can create mates between elliptical, conical, and parabolic edges, sketch entities,
and other geometry that are related as follows:

• Coincident to a point
• Tangent to a line, circle, cylinder, sphere, or ellipse
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Creating Spherical Mates
In this example, you mate two spherical surfaces.

Opening the Assembly and Starting the Mates
First, you open an assembly, and then you set up a spherical mate.

1. Open install_dir\samples\whatsnew\assemblies\spherical_mates\ball
ring.SLDASM and save it as my ball ring.SLDASM.

2. Click Mate (Assembly toolbar) or Insert > Mate.
3. Select the ring Face<2>@ring-1 and the sphere Face<1>@ball-1.

The default tangent mate is selected.
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4. Click .

5. Close the document without saving it.

Viewing Mates from Reference Geometry
You can open the View Mates window for any selected reference geometry, such as
planes, axes, or other reference geometry.

To view mates for selected reference geometry:

1. Open an assembly.
2. Select mated reference geometry, for example, a mated plane or axis.

3. Click View Mates .
The View Mates window lists mates that reference the selected reference geometry.
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Mirroring Asymmetric Components
You can use a bounding box to position a mirrored component with respect to the mirror
plane for mirroring asymmetric components.

For mirroring asymmetric components, using bounding boxes to define the mirror plane
provides better results than using the center of mass.

To mirror asymmetric components in an assembly:

1. ClickMirror Components (Assembly toolbar) or Insert >Mirror Components.
2. In the PropertyManager, for Selections, select the Mirror plane and the

Components to mirror and click Next .
3. For Mirror type, select an option:

DescriptionOption

Positions the mirror so that the center of a bounding box
for the selected components is mirrored about the mirror
plane.

Bounding box

Positions the mirror so that the center of mass of the
selected components is mirrored about the mirror plane.

Center of mass

4. Set other options and click .
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Asymmetric Mirrored Components Examples
The following examples show the difference between a bounding box type mirror and a
center of mass type mirror.

Bounding box type mirror

Center of mass type mirror

Multiple Configuration Updates
The software detects conflicts when an assembly contains subassemblies with a
single-configuration component that is driven by an in-context relationship to a component
with multiple configurations. The results appear in the AssemblyXpert dialog box.

The in-context relationships can arise from updates to equations or external references.

When the AssemblyXpert dialog box appears, to update the configurations, click Fix It.

Patterns

Curve and Sketch Driven Patterns
You can define curve driven and sketch driven patterns for assemblies.

Curve driven patterns can contain tangential lines to locate components driven by a curve.
Sketch driven patterns can contain a centroid or a selected point to locate components
driven by a sketch.
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Previously, these patterns were available for parts only.

Click Assembly > Insert > Component Pattern, and select Curve Driven or

Sketch Driven .

Pattern Driven Patterns
You can create a pattern using an underlying component pattern.

The Feature Driven Pattern has been renamed to Pattern Driven Pattern because
it is no longer limited to features.

You can use a component, in addition to a feature, to drive a pattern driven pattern. The
component can be in the same assembly or within a subassembly. The component can
also be driven by an assembly-level pattern such as a Linear, Circular or Hole Wizard
series, or by a feature driven pattern.

Click Insert > Component Pattern > Pattern Driven .

Selecting Components by Size
To select assembly components by size:

1. Click Tools > Component Selection > Select by Size.
2. In the dialog box, enter a value for the percentage of assembly size to select and

click OK.
To display a preview of your selections, select Preview selection.
The components that are smaller than the percentage of assembly size you enter are
selected.
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Selecting Configurations from the Context Toolbar
When you select components or subassemblies, a context toolbar appears. When your
selection has multiple configurations, you can change the configuration from the context
toolbar.

To change the component configuration in an assembly:

1. Click the component or subassembly.
2. In the context toolbar, select a configuration from the list at the top.

3. Click .

Shortcuts for Suppressing Items in Design Tables
The string values suppressed and unsuppressed are valid values for selected design
table columns. You can use shortcuts for these string values in design tables.

You can substitute the numerical value 1 for the string suppressed, and 0 for the string
unsuppressed to achieve the same result. You can also enter the strings s for suppressed
and u for unsuppressed. To enter shortcut values for suppressed or unsuppressed in
design tables:

1. Type 1 or s for suppressed.
2. Type 0 or u for unsuppressed.

Toggling Between Flexible and Rigid States
You can toggle between the flexible and rigid states for subassemblies from the
subassembly shortcut bar.

To make a rigid subassembly flexible:

1. Open an assembly containing a rigid subassembly.
2. In the FeatureManager design tree, click the rigid subassembly, and click Flexible

or Rigid .

You can also click Flexible or Rigid (Assembly toolbar).
To make a flexible subassembly rigid, select the subassembly and click Flexible or

Rigid .
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For models with multiple configurations, following this method affects only the
active configuration.

Updating Assembly Graphics
You can set an option to update model graphics data for components when you save
assemblies, to prevent display list data from becoming out-of-date.

To update assembly graphics:

1. Click Options (Standard toolbar) or Tools > Options.
2. On the System Options tab, click Assemblies and select Update model graphics

when saving files.
3. Click OK.
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6
CircuitWorks

Available in SolidWorks Premium.

This chapter includes the following topics:

• Associating CircuitWorks Components with SolidWorks Models
• CircuitWorks and SolidWorks Flow Simulation
• CircuitWorks Library Component Wizard
• CircuitWorks Setup Wizard
• Exporting from SolidWorks to CircuitWorks
• Importing Properties from ECAD Files
• Syncing Selected ProStep EDMD Changes
• Specifying Component Names in the CircuitWorks Tree
• Support for ProStep EDMD Files
• User Interface

Associating CircuitWorks Components with SolidWorks
Models

You can associate and disassociate CircuitWorks® tree components with SolidWorks part
or assembly files.

To associate a CircuitWorks component with a model:

1. Open an ECAD file in the CircuitWorks application.
2. From the CircuitWorks dialog box, in the CircuitWorks tree, expand the Components

folder.
3. Right-click a component and click Associate Model.
4. In the Open dialog box, select the SolidWorks part or assembly file to associate with

the component and click Open.
To dissociate an associated component in the CircuitWorks dialog box, right-click the
component and click Dissociate Model.

You are prompted to delete the dissociated SolidWorks model when you dissociate
the model from a selected component.

CircuitWorks and SolidWorks Flow Simulation
With CircuitWorks, an add-in to SolidWorks Premium, you can create 3D models from
the file formats written by most electrical computer-aided design (ECAD) systems. You
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can collaborate to design printed circuit boards (PCBs) that fit and function in SolidWorks
assemblies.

You can import the following CircuitWorks ECAD file PCB or component thermal properties
to SolidWorks Flow Simulation:

• Dielectric and conductor density
• Specific heat
• Conductivity for PCBs
• Conductivity for volumetric heat sources from components

When you conduct thermal analysis with SolidWorks Flow Simulation, the SolidWorks
model references the imported customer thermal properties.

Two options in the Flow Simulation tree facilitate setting up the Computational Fluid
Dynamics (CFD) analysis for cooling simulation of electronic components:

• Right-click Heat Sources and select Import volume source frommodel. Select the
heat sources to import in Item properties.

• Right-click Printed Circuit Boards and select Import Printed Circuit Boards from
model. Select the PCBs to import in Item properties.

CircuitWorks Library Component Wizard
You can use the CircuitWorks Library Component Wizard to select SolidWorks components
to add to the library and to set them up for use with CircuitWorks.

The wizard guides you to assign the component orientation and to specify how the
CircuitWorks software determines the package name and part number from the component
file name or its custom properties.

To open the CircuitWorks Component Library Wizard, from the CircuitWorks Component
Library dialog box, click File > Add Components.
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CircuitWorks Setup Wizard
You can use the CircuitWorks Setup Wizard to set up important CircuitWorks options for
connecting your ECAD data to the CircuitWorks and SolidWorks applications.

The wizard guides you to set up a location for the CircuitWorks Library and to specify
which ECAD file properties can be used to match to a SolidWorks model. You can also
download SolidWorks models of electronic parts to use in circuit board design.

The CircuitWorks Setup Wizard starts the first time you add in CircuitWorks. You can also
start the wizard from the CircuitWorks Options dialog box.

Exporting from SolidWorks to CircuitWorks
You can use the CircuitWorks Export Wizard to identify the circuit board features that
make the resulting CircuitWorks model useful for export to an ECAD system.

To export a SolidWorks model to the CircuitWorks application:

1. From SolidWorks, click Export to CircuitWorks (CircuitWorks toolbar) or
CircuitWorks > Export to CircuitWorks.

You can also export a SolidWorks model by clicking Import Model (Tools
toolbar) in CircuitWorks.

The CircuitWorks Export Wizard appears.

2. Follow the wizard to set up your circuit board model components for use with the
CircuitWorks software.
You can specify the following information:

Specifies that the component is electrical, mechanical,
or a circuit board.

Component Type

For a circuit board, specifies the feature that represents
the top of the board.

Top of the Board

For a circuit board, specifies the feature that represents
the outline of the board.

Board Outline

For a mechanical component, specifies the feature that
represents the outline of the component.

Mechanical Outline

For an electrical component, specifies the feature that
represents the outline of the component.

Electrical Outline

For a circuit board, specifies the features that represent
nonplated holes.

Nonplated Holes

For a circuit board, specifies the features that represent
plated holes.

Plated Holes
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For a circuit board, specifies the features that define
keep-out or keep-in areas.

Keep-out and Keep-in
Areas

3. Click Finish.

Importing Properties from ECAD Files
You can import ECAD file thermal and other properties as SolidWorks Model custom
properties.

To import properties from an ECAD file into a SolidWorks model:

1. Open the ECAD file in the CircuitWorks application.

2. From the CircuitWorks application, click the CircuitWorks application menu , and

then click Options .

You can also access CircuitWorks options from the SolidWorks application by clicking
CircuitWorks > CircuitWorks Options.

3. Select Properties .
4. To add custom board properties to SolidWorks board models you build, select Add

these properties to the SolidWorks board model.
5. To add custom component properties to the SolidWorks component models you build,

select Add these properties to the SolidWorks component models.
6. Click OK.

Syncing Selected ProStep EDMD Changes
When syncing ProStep EDMD changes with your ECAD design system, you can select the
changes to export. You can export sets of changes as an .idz file.

Before sending ProStep EDMD file information, you must enable ProStep EDMD file syncing
in the CircuitWorks application.

To open a ProStep EDMD file in the CircuitWorks application, from SolidWorks, click
CircuitWorks > Open ECAD File, select the file, and click Open.

To sync selected ProStep EDMD changes:

1. On the EDMD tab, click Sync with ECAD .
The Sync with ECAD dialog box displays a summary of the messages to be sent with
the ProStep EDMD data.

2. Select messages to send:

• To send most messages, click Change and clear the messages to withhold.
• To send a few messages, select clear Change and select the messages to send.

3. Click OK.
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Exporting ProStep EDMD Changes as IDZ Files

To export ProStep EDMD changes as compressed .idz files:

1. To display the CircuitWorks Options dialog box, do one of the following:

• From the CircuitWorks application, click the CircuitWorks application menu ,

and then click Options .
• From the SolidWorks application, click CircuitWorks > CircuitWorks Options.

2. In the CircuitWorks Options dialog box, click ProStep EDMD .
3. For Default file format, select *.idz (compressed) and click OK.

Specifying Component Names in the CircuitWorks Tree
You can specify how components are named in the CircuitWorks tree. For example, you
can display the ECAD part number followed by the ECAD part name.

To specify component labels in the CircuitWorks tree:

1. To display the CircuitWorks Options dialog box, do one of the following:

• In the SolidWorks application, click CircuitWorks > CircuitWorks Options.

• From the CircuitWorks application, click the CircuitWorks application menu ,

and then click Options .

2. Click General .
3. Under CircuitWorks tree, select options for Show components in the tree using:

DescriptionOption

Specifies the first portion of the name by ECAD component
name, or ECAD part number.

First part

Specifies an optional character string to separate the first
part of the name from the secondary part.

Delimiter

Specifies the optional second portion of the name.Second part

4. Click OK.

Support for ProStep EDMD Files
You can import or export ProStep EDMD 3.0 files.

To open a ProStep EDMD 3.0 file:

1. From SolidWorks, click Open ECAD File (CircuitWorks toolbar) or CircuitWorks
> Open ECAD File.

2. From the Open ECAD File dialog box, select the ECAD file and click Open.
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3. To import the file into the SolidWorks application, close open SolidWorks models, and

in the CircuitWorks dialog box, click Build Model and then click Build.
The model is built and opened in the SolidWorks application.

4. To export the file back into the CircuitWorks application, from the SolidWorks software,

click Export to CircuitWorks (CircuitWorks toolbar) or CircuitWorks > Export
to CircuitWorks.

User Interface
You can multiselect items in the CircuitWorks tree and display or edit common properties.
You can also access zoom and view options by right-clicking in CircuitWorks preview area.

To access Zoom and View context menus:

1. From SolidWorks, click Open ECAD File (CircuitWorks toolbar) or CircuitWorks
> Open ECAD File.

2. From the Open ECAD File dialog box, select the ECAD file and click Open.
3. In the CircuitWorks application, right-click the preview area.
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7
Configurations

This chapter includes the following topics:

• Additional Properties for Toolbox Components
• Applying Configurations to Equations
• Selecting Configurations from the Context Toolbar

Additional Properties for Toolbox Components
Three read-only properties, Part Name, Standard, and Specification, are available in
Toolbox settings and appear in the Configure Component PropertyManager for standards
that have an existing Designation, such as AS, DIN, GB, ISO, IS, and KS. The properties
are available in drawing or assembly BOMs.

To display a Toolbox property:

1. Add a column to the BOM by double-clicking the top of a BOM column, just above the
column heading.
A dialog box appears with the Column type and Property name lists.

2. Select TOOLBOX PROPERTY from the Column Type list.
3. Select the property you want displayed in that column from the Property name list.

Applying Configurations to Equations
You can apply configurations to equations and global variables.

See Configurable Equations.
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Selecting Configurations from the Context Toolbar
When you select components or subassemblies, a context toolbar appears. When your
selection has multiple configurations, you can change the configuration from the context
toolbar.

To change the component configuration in an assembly:

1. Click the component or subassembly.
2. In the context toolbar, select a configuration from the list at the top.

3. Click .
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8
SolidWorks Composer

SolidWorks® Composer™ software streamlines the creation of 2D and 3D graphical contents
for product communication and technical illustrations.

These products are available:

• SolidWorks Composer
• SolidWorks Composer Check
• SolidWorks Composer Path Planning
• SolidWorks Composer Player
• SolidWorks Composer Player Pro
• SolidWorks Composer Sync
• SolidWorks Composer Enterprise Sync

This chapter includes the following topics:

• Automatically Hiding Annotations
• Composer APIs
• Coordinate Labels
• Wrapping Annotation Text

Automatically Hiding Annotations
You can automatically hide annotations when the anchor is hidden in the current scene.

In the Properties dialog box, under Auto hide, set the appropriate option.

DescriptionOption

Disables Auto hide.Disable

Enables Auto hide if the annotation's
anchor is hidden by any object, even the
object linked by the annotation.

Standard

Enables Auto hide if the annotation's
anchor is hidden by any object other than
the linked object.

The number of annotations might impact
system performance.

Advanced
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Composer APIs
Several new APIs have been added to the SolidWorks Composer API.

DescriptionAPI

Creates a custom view that captures only
the camera's position.

CreateView()

Creates a view that captures the entire
viewport state.

CreateCameraView()

Deletes the specified view.DeleteView()

Updates the specified view.UpdateView()

Coordinate Labels
Coordinates have properties that let you customize the label's text with the properties of
the actor.

In the Properties dialog box, under Text, use the Text property to specify which property
or meta-property appears as the coordinate label's text. Use the Parent (level) property
to specify the actor whose Text value appears as the coordinate label's text.

These properties help you avoid creating multiple labels to display simple information.

Wrapping Annotation Text
You can wrap text in annotation labels and callouts.

In the Properties dialog box, under Text, selectWrap. You can specify theWrap width
in millimeters. You can also drag the resize anchor in the text box to resize the width.
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9
SolidWorks Costing

Available in SolidWorks Professional and SolidWorks Premium.

This chapter includes the following topics:

• Converting Circular Cut Paths to Drilled Holes
• Costing Options
• Costing Reports
• Creating a Limited-access Costing Template
• Custom Properties for Costing
• Generating Costing BOMs
• Including Percent Scrap in Sheet Metal Costing
• Modifying Machined Part Setup
• Adding Template Comments to Drill, Mill, or Turn Operations
• Organization of the Setup Folder
• Setting Model Materials
• Simplifying Cost Estimates
• Updating Template Material Cost Data
• Using Multibody Parts to Define Removed Material
• Volume Features

Converting Circular Cut Paths to Drilled Holes
To facilitate costing of sheet metal parts from machining templates, you can convert
circular cut paths into drilled holes.

You can also revert drilled holes back to cut paths.

To convert a circular cut path to a drilled hole for a sheet metal part:

1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager) or
Tools > Costing.

2. In the Costing Task Pane, click Costing Options (upper left corner).
3. In the dialog box, select Use machining template for sheet metal parts and click

OK twice.
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4. To set up the cost estimate, in the Costing Task Pane, select the template and material.

Keep Plate as the Stock Body selection.

5. In the CostingManager, expand the Cut Paths folder, right-click a circular cut path,
and click Change to Drill.

To revert the drilled hole to a cut path, expand the Holes folder, right-click the
drilled hole, and click Change to Cut Path.

Costing Options
You can define or override system-level costing options in the Costing Options dialog box.

You can select sheet metal Costing options to do the following:

• Estimate the cost of sheet metal parts from a machining template.
• Apply fixed custom costs to sheet metal features, such as bends, hems, or library
features.

You can select machining Costing options to:

• Recognize removed material as volume features.
• Assign a default machining operation to volume features, or calculate the cost of volume
features by assigning a per volume cost to the removed material.

• Assign the default surface finishing operation for milling and turning on machined parts.
• Override template settings for offset-based finishing. You can type a value for the offset
from the machined surface for finishing and semifinishing operations.

To access the Costing Options dialog box, in the Costing Task Pane, click Costing Options

(upper left corner).

Estimating Sheet Metal Part Costs from a Machining
Template
To include the cost of plate geometries in sheet metal parts, you can use a machining
template for sheet metal part costing.

To use a machining template for costing a sheet metal part:

1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager) or
Tools > Costing.

2. In the Costing task pane, click Costing Options (upper left corner).
3. In the dialog box, select Use machining template for sheet metal parts.
4. Set other options and click OK.

You can select Save as Costing default settings to retain the Costing Options
dialog box settings for future use.
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Costing Reports

Customizing Costing Report Headers
When creating Costing reports, you can enter form data in the Costing Report dialog box,
such as your company logo and contact information. You can also enter information about
the customer quote you are preparing. Your entries appear in the report headers.

To customize report headers in a costing report:

1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager) or
Tools > Costing and calculate the cost of the part.

2. At the bottom of the Costing Task Pane, click Generate Report .
3. In the Report Options dialog box, expand Company information, select the options,

and type the data.

DescriptionOption

Specifies your company name.Company

Specifies your company address.Address

Specifies your company website.URL

Uploads a file of type .jpg, .gif, .png, or .tif to the report
header.

You can upload images of sizes up to 300 x 150 px.

Logo

You can also enter your name and contact information on the report form.

4. Expand Quote information, select the options, and type the data.

• Quote number
• Request for quote number
• Customer company
• Customer contact name
• Customer contact information
• Quote prepared by

5. To view the published report, select Show report on publish.
6. Click Publish.

The report appears.

7. Close the report.
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Exporting Costing Reports as Microsoft Excel Files
You can export costing reports as either .docx or .xlsx files.

To export a costing report as a Microsoft .xlsx file:

1. At the bottom of the Costing Task Pane, click Generate Report .
2. In the dialog box, for File type, select .xslx.
3. Select Show report on publish.
4. Set other options and click Publish.

The report appears in Microsoft Excel.

5. Close the report.

To generate a Microsoft Word file, select .docx for File type.

Creating a Limited-access Costing Template
You can create a limited-access Costing template to share with other users. You can select
limited-access templates in the Costing Task Pane, but you cannot view or edit them in
the Costing Template Editor application.

To create a limited-access Costing template for a part:

1. To open a Costing template, do one of the following:

• From the Windows Start menu, click All Programs > SolidWorks version >
SolidWorks Tools > Costing Template Editor version.

• With a part open:

1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager)
or Tools > Costing.

2. In the Costing Task Pane, select a template to save, and click Launch Template
Editor.

2. In the Costing Template Editor application, in an open template, click Save >
Save As Limited Access Copy.

You might have to click Save As instead of Save .

3. In the Save As dialog box, for File name, enter a name and click Save.
The template is saved as a protected .zip file.

4. Close the Costing Template Editor application.
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Custom Properties for Costing
You can assign cost-specific custom properties to SolidWorks documents.

Specifies the type of material used when costing the
part.

Cost - Material Name

Specifies the type of stock used to cost the part.Cost - Stock Type

Specifies the name of the template used to estimate
the part cost.

Cost - Template Name

Specifies the calculated cost of material used.Cost - Material Cost

Specifies the calculated manufacturing cost.Cost - Manufacturing Cost

Specifies the time at which the cost was most
recently calculated.

Cost - Time of Cost Calculation

Specifies the size of the stock used to manufacture
the part.

Cost - Stock Size

Specifies the calculated cost of the part.Cost - Total Cost

For more information, see SolidWorks Help: Adding Costing Information to File Properties.

Generating Costing BOMs
You can generate assembly or drawing BOMs that display component costs.

To generate a costing BOM:

1. Click Insert > Tables > Bill of Materials.
2. Select the Costing BOM template bom-costing.sldbomtbt.

3. Select other options and click .

Including Percent Scrap in Sheet Metal Costing
To include scrap material in the cost of a sheet metal part, you can designate a percentage
of the part as scrap.

To designate a portion of a sheet metal part as scrap:

1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager) or
Tools > Costing.

2. In the Costing Task Pane, under Blank Size, type a percentage value for Percent
scrap.
The value you type for Percent scrap designates a portion of the material defined
in your Area to cost selection as scrap material.

82

SolidWorks Costing



Modifying Machined Part Setup
You can specify machined part setup time on the Machine tab of the machining template.

For each machine, you can specify the following:

Specifies the time it takes to load a part into a machine
and then unload it for each setup operation.

Load/Unload Time

Specifies the time it takes to set up fixtures and other
machining process setup operations.

Operation Setup Time

Specifies options for applying the operation setup time to
costing.

Setup Distribution

To modify setup parameters for machined parts:

1. To open a Costing machining template, do one of the following:

• From the Windows Start menu, click All Programs > SolidWorks version >
SolidWorks Tools > Costing Template Editor version.

• With a part open:

1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager)
or Tools > Costing.

2. In the Costing Task Pane, select a template, and click Launch Template Editor.

2. If your machining template is not open, in the Costing Template Editor application,

click Open , select the machining template and click Open.
3. Select the Machine tab, and, for each machine, enter data in the appropriate columns.

To set the setup operation parameters for cutting operations, under operations,
select Cut (Plate Stock).

4. Save the template and close the application.

Adding Template Comments to Drill, Mill, or Turn Operations
You can add comments to mill, drill, or turn tools in the machining templates.

To add comments to the machining templates:

1. To open a Costing machining template, do one of the following:

• From the Windows Start menu, click All Programs > SolidWorks version >
SolidWorks Tools > Costing Template Editor version.

• With a part open:
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1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager)
or Tools > Costing.

2. In the Costing Task Pane, select a template, and click Launch Template Editor.

2. If your machining template is not open, in the Costing Template Editor application,

click Open , select the machining template and click Open.
3. Select the Drill, Mill, or Turn tab, and type comments in the Comments column.
4. Save the template and close the application.

Organization of the Setup Folder
The CostingManager Setup folder for machined parts has been reorganized to display
setup costs for operation setup, custom setup, and loading or unloading parts.

Operation Setup includes fixturing, setup, and programming.

Custom Setup includes painting, anodizing, or other custom operations.

Load and Unload Setup includes the loading and unloading of parts into and out of
fixtures.

Setting Model Materials
You can set the model material for a part from the material you select in the Costing Task
Pane.

To set the material for a part from Costing Task Pane selections:
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1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager) or
Tools > Costing.

2. In the Costing Task Pane, under Material, select the values for Class and Name.
3. To set your material selections as the model material, click Set Material.

Part material settings are automatically selected in the Costing Task Pane when
the part material is also a material listed in the selected template.

Simplifying Cost Estimates
You can estimate the cost of machined parts, relying on a selected template only for
material selection.

To simplify the cost estimate, select the following machining options in the Costing Options
dialog box, and calculate the cost of the removed material:

When applied to the material to be removed from a
machined part, specifies that volume features determine
the amount of material to be removed.

Use customizable volume
feature recognition

Lets you assign a fixed cost per unit volume of removed
material, rather than calculate the cost based on tool sizes
and removal rates.

Cost per volume removed

Calculates the per-unit-volume cost of semifinishing and
finishing, based on an offset distance value rather than
on template data. The offset distance value is the
operation offset distance from the machined surface.

Override template settings
for offset-based finishing

To set up options for simplified cost estimates for a part:

1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager) or
Tools > Costing.

2. In the Costing Task Pane, click Costing Options (upper left corner).
3. In the dialog box, for Machining options, select the following:

a) Under Removedmaterial processing, select As customizable volume feature
recognition.

b) Under Volume feature calculation, select Cost per volume removed and type
cost values for Roughing, Semi-finishing, and Finishing.

c) Under Surface finishing for mill or turn operations, select Override template
settings for offset-based finishing and type values for Semi-finishing and
Finishing.

4. Set other options and click OK twice.
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Updating Template Material Cost Data
You can export machining template material property data to an .xlsx file and modify
the cost data in the spreadsheet. You can upload the material cost data from the .xlsx
file to the Costing machining template.

To update material cost data in a Costing machining template:

1. To open a Costing machining template, do one of the following:

• From the Windows Start menu, click All Programs > SolidWorks version >
SolidWorks Tools > Costing Template Editor version.

• With a part open:

1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager)
or Tools > Costing.

2. In the Costing Task Pane, select a template, and click Launch Template Editor.

2. If your machining template is not open, in the Costing Template Editor application,

click Open , select the machining template and click Open.
3. Select Stock Material and click Export.
4. To save the material properties data as an .xlsx file, type a name and click Save.

The file opens in Microsoft Excel, where you can modify the cost data.

You must not add rows or columns to the spreadsheet.

5. To import the updated material cost data:
a) In the machining template, select Stock Material and click Update.
b) Select the edited .xlsx file and click Open.
Updated costs are highlighted in the template Cost column.

6. Save the template and close the application.

Using Multibody Parts to Define Removed Material
You can use multibody parts to define the removed material in a part.

You can assign operation costs to bodies that define the removed material. Alternatively,
you can assign a cost per volume removed. For example, you can compute the cost of
post manufacturing operations on cast parts by assigning operation costs to the bodies.
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To assign operation costs or the cost per volume removed to a multibody part:

1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager) or
Tools > Costing.
The default multibody template is selected in the Costing task pane. Default sheet
metal and machining templates are in effect, depending on the type of body.

2. Assign a custom operation to the bodies:
a) Under Body List, select the bodies to assign a custom operation to.
b) For Type of body, select Custom/Removed Material.
c) Under Operation Options, select Custom operation and select a drill, turn, or
mill operation.
The selected machining template assigns the drilling, turning, or milling costs.

3. Apply cost per volume to the bodies:
a) Under Body List, select the bodies to assign the custom cost per unit volume to.
b) For Type of body, select Custom/Removed Material.
c) Under Operation Options, select Custom cost per volume and type a value.

You can assign different costs per volume for different sets of bodies in a
multibody part.

4. After completing the Costing setup for all of the bodies, you can begin or update the
cost estimation.

Estimating Post-machining Costs for Cast Parts
When you finish a cast part, you might have costs associated with post-machining
operations, such as drilling or milling. In this example, you open a cast part, define the
removed material, and estimate the cost of removing material from the cast part.

Cast Stock Part
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Removed Material

Finished Part

To estimate the cost of the finished part, you can combine cost estimates of these two
parts:

• The cast aluminum stock part
• The material that is removed from the cast part during post-machining operations

In this example, you estimate the cost of removing material from the cast part.

Since finishing the cast part entails removing material, you can estimate the cost of
finishing a cast part by estimating the cost of removing material from the cast part, either
by assigning a milling or drilling operation for the removal, or by assigning a cost per
volume of material removed. With either method, you first define a multibody part to
represent the material to be removed from the cast part.
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Opening the Parts
First, you open two parts: A finished cast part, and a part that represents the cast stock.

1. Open install_dir\samples\whatsnew\costing\cast_part_volume_removed\
CAST_CYLINDER.SLDPRT.
This is a finished cast part with some drill and mill finishing operations.

2. Save the part as my_cast_cylinder.sldprt.
3. To view the part used to represent the stock body for the cast part, open install_dir\

samples\whatsnew\costing\cast_part_volume_removed\
CAST_CYLINDER_STOCK.SLDPRT.
This is the cast part with the drilled holes and milled portions suppressed.

4. Close install_dir\samples\whatsnew\costing\cast_part_volume_removed\
CAST_CYLINDER_STOCK.SLDPRT.

Defining the Removed Material
Aside from setup costs, the cost of the material removed during finishing operations
determines the cost of the finishing operations. Next, you define a multibody part for the
material removed during post-machining operations.

One way to define a multibody part for the removed material is to subtract the stock body
for the cast part from the finished part. What remains is the volume of material removed
during the post-machining operations.
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1. From the ConfigurationManager for my_cast_cylinder.sldprt, right-clickDefault
[ my_cast_cylinder ] and click Add Derived Configuration.

2. In the PropertyManager, for Configuration name, type Costing Example, and click

.
3. Add the stock part to the finished part:

a) Click Insert > Part.
b) Select install_dir\samples\whatsnew\costing\cast_part_volume_removed\

CAST_CYLINDER_STOCK.SLDPRT, and click Open.

4. Drag the stock part to the finished part and click the bodies when they match up.
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5. Click Insert > Features > Combine.
6. In the PropertyManager, for Operation Type, select Subtract.
7. Subtract the two bodies to define the part for the volume of removed material:

a) In the FeatureManager design tree, expand Solid Bodies (2).
b) For Main Body, select <CAST_CYLINDER_STOCK>.
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c) For Bodies to Subtract, select Flange Holes, and click .
d) In the Bodies to Keep dialog box, select All bodies, and click OK.

Calculating Removed Material Costs
Next, you calculate the cost of the removed material.

1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager) or
Tools > Costing.
In the Costing Task Pane, the software selects the default multibody template, which
references both a sheet metal and a machining template.

2. Apply a fixed cost to the bolt-shaped body:
a) In the Costing Task Pane, under Body List, select a body, such as Combine1[2].

Your selection might differ, depending on how you set up the bodies.

b) For Type of body, select Custom/Removed Material.
c) Under Operation Options, select Custom cost and type 2.00.

92

SolidWorks Costing



3. Assign a custom drill operation to the largest body:
a) Under Body List, select another body, such as Combine1[1].

b) For Type of body, select Custom/Removed Material.
c) Under Operation Options, select Custom operation and select HSS Drill.
d) Under Material, for Class, select Aluminum Alloys.
The software derives operation costs for the material from the machining template.

4. Apply cost per volume removed to the remaining bodies:
a) Under Body List, select all of the remaining bodies.

b) For Type of body, select Custom/Removed Material.
c) Under Operation Options, select Custom cost per volume and type 1.50.

5. Click Begin Cost Estimation.
The estimated cost of removing material to finish the part is displayed.

Modifying Body Costs
Next, you modify settings and update the multibody part cost estimate.

1. In the CostingManager, expand Custom Bodies.
2. To change the custom cost of removing the Combine1[3] body, right-click

Combine1[3] and click Apply Cost Override.
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3. Enter 0.11 for the custom cost.

You can also change the cost in the CostingManager, by double-clicking the cost.

The software updates the cost estimate.

4. To modify the body costs, in the CostingManager, right-click Combine1[1], and click
Change Body Settings.

5. In the Costing Task Pane, under Operation Options, select Custom cost per volume
and type 2.50.

6. Click Begin Cost Estimation.
The software updates the cost estimate.

7. Close all parts without saving them.

Volume Features

Assigning Machining Operations to Volume Features
To assess the cost of a part that you create from a stock body, you can assign machining
operations to volume features.

To assign machining operations to open parts that have volume features:

1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager) or
Tools > Costing.

2. In the Costing Task Pane, select the template, material, and stock body.
The software estimates the part cost.

3. In the CostingManager, expand the machining operation folder containing the volume
feature: Mill Operations, Hole Operations, or Turn Operations.

4. To change the machining operations type, right-click the volume feature, and click a
command to convert to another operation type:

DescriptionOption

Converts mill or turn operations to drill operations.Convert to Drill

Converts mill or drill operations to turn operations.Convert to Turn

Converts turn or drill operations to mill operations.Convert to Mill

For example, if the volume feature appears under Mill Operations, right-click the
volume feature, and click Convert to Drill or Convert to Turn.

5. To change the type of tooling operation, right-click the volume feature, and click
Processing > Tooling and select a different type of tooling operation.
For example, for a flat-end milled volume feature, right-click the volume feature, and
click Processing > Tooling > Ball End Mill.
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Converting Slot Features to Volume Slot Features
Volume slot features are volume features that are created from standard slot features.
You can convert standard slots into volume slots, and you can revert volume slots to
standard slots.

By converting standard slot features to volume slots, you can use the custom volume
feature options to improve cost estimates.

To convert a slot feature in a part to a volume feature for Costing:

1. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager) or
Tools > Costing.

2. In the Costing Task Pane, select the template, material, and stock body.
The software estimates the part cost.

3. In the CostingManager, expand Mill Operations.
The application identifies existing slot features.

4. Right-click a slot feature and click Convert to Volume Slot.
The cost is updated.

To revert a volume slot feature back to a slot, in the CostingManager, right-click
the volume slot feature and click Revert to Standard Slot.

Saving Volume Features as Parts
Volume features represent the removed material in a part.

For some parts, to determine cost of the removed material, you must convert a set of
volume features into a multibody part. Before you can treat a set of volume features as
a multibody part, you must first save the volume features as parts.

To save a volume feature as a part:

1. Estimate the cost of a machined part:

a) Click Costing (Tools toolbar or the Evaluate tab on the CommandManager) or
Tools > Costing.

b) In the Costing Task Pane, select the template, material, and stock body.

2. In the CostingManager, expand the folders to display the volume feature.
3. Right-click the volume feature, and click Insert into New Part.
4. In the dialog box, enter a file name and click Save.
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Volume Features for Cylindrical Stock Bodies
The software creates volume features for complex machining operations in cylindrical
stock bodies. You can use a volume feature cost estimate to determine the cost of drilling,
turning, and milling operations on the part.

Costing Volume Features Example
In this example, you learn about using setup operations and volume features in Costing.

Opening the Part and Setting the Material
First, you open a turned part, and set the material properties.

1. Open install_dir\samples\whatsnew\costing\turned_part\turn_example.sldprt,
and save the part as my_turn_example.sldprt.

2. Click Costing (Tools toolbar or the Evaluate tab on the CommandManager) or
Tools > Costing.

3. In the Costing Task Pane, under Machining Template, select the default metric
machining template, machiningtemplate_default(metric).

4. In the Costing Task Pane, under Material, select the following:

• For Class, select Aluminum Alloys.
• For Name, select 6061 Alloy.
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5. Under Stock Body, for Type, select Cylinder.

6. To set your material selections as the model material, click Set Material.
7. Under Quantity, select the following:

• For Total number of parts, enter 80.
• For Lot size, enter 80.

The software updates the cost estimate in the Task Pane.

Checking Setup Operations and Creating Volume Features
Next, you check the setup operations folder, define the removed material as volume
features, and add a setup operation.

1. In the CostingManager, expand the Setup folder, and expand the Operations Setup
folder and its dependent folders.

2. In the Costing Task Pane, click Costing Options (upper left corner).
3. In the dialog box, for Machining Options, under Removed material processing,

select Use customizable volume feature recognition and click OK twice.
The software recognizes the removed material as volume features.

4. In the CostingManager, right-click Operations Setup, and click Add Setup
Operation.

5. Right-click Volume 2 and click New Setup Operation.
Volume 2 is moved to a new setup folder.

6. Drag Volume 4 - Volume 10 to the new setup folder.
7. Expand the Load and Unload Setup folder to display the new operation folders.
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Bypassing Templates for Cost Estimates
Next, you select options to obtain a cost estimate that is independent of a selected
template, except for the supplied materials information.

1. In the Costing Task Pane, click Costing Options (upper left corner).
2. In the dialog box, for Machining Options select the options:

a) Under Volume Feature Calculation, select Cost per volume removed.
b) Type the following values: for Roughing type 0.05, for Semi-finishing, type

0.01, and for Finishing, type 0.01
In general, select values that are appropriate for the part costs, based on your
experience.

c) Under Finish processing (Mill/Turn Operations), select Override template
settings for offset-based finishing and type .01 for Semi-finishing and for
Finishing.
The finishing and semifinishing values define a displacement distance for finishing
and semifinishing operations.

To apply these settings every time you use the Costing tool, select Save as Costing
default settings.

3. Click OK twice.
4. In the CostingManager, expand the Mill Operations folder.
5. Right-click Volume 3 and click Add Operation > Finishing.

The software updates the cost estimate.

6. To revert back to template calculations for Volume 3, right-click and click Volume 3
and click Processing > Tooling > Flat End Mill.
The software updates the cost estimate, and evaluates the milling cost of Volume 3,
based on the machining template.

Changing Machining Operations
Next, you change machining operations on selected volume features.

1. To calculate the removal of the material in Volume 2 by an HSS drilling operation, in
the CostingManager, in the Mill Operations folder, right-click Volume 2 and click
Convert to Drill > HSS Drilling.
The software updates the cost estimate, and moves Volume 2 from the Mill
Operations folder to the Hole Operations folder.

2. To calculate the removal of the material in Volume 3 by an OD turning operation, in
the Mill Operations folder, right-click Volume 3 and click Convert to Turn > OD
Turning.

98

SolidWorks Costing



The software updates the cost estimate, and moves Volume 3 from the Mill
Operations folder to the Turn Operations folder.

3. Close the document without saving changes.
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10
Drawings and Detailing

This chapter includes the following topics:

• Balloons
• Bill of Materials (BOM)
• Dimensions
• Drawing Views
• Other Annotations
• Sheet Formats
• Automatically Splitting Tables Horizontally at a Row

Balloons

Additional Magnetic Line Soft Snaps
Soft snaps at every 15 degrees are available to facilitate placing or changing the angle
of magnetic lines.

Balloon Arrow Attached to Model's Vertex
When you select a balloon, and select and drag the tip of the balloon's arrow that is
attached to a vertex of a model, the arrow moves, not the drawing view.

Leaders
You can set a balloon's leader to always attach to the balloon when quantity is specified.

To set a balloon's leader to always attach to the balloon:

In the Balloon PropertyManager, click More Properties, and select Always Attached

to Balloon . To set a balloon's leader to break around quantity, select Break Around

.
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Quantity Placement on Balloons
In the Balloon PropertyManager, you can control the Distance between a balloon's border
and its quantity.

Reattachable Balloons
You can reattach any balloon (including dangling balloons within a stack) to associate it
with any component within the same drawing view.

To reattach a balloon:

1. Right-click the balloon and click Reattach.
2. Click a component within the same drawing view to attach the balloon.

Balloons within a stack show information from the new selection. Balloons with leaders
automatically point to the new selection.

Bill of Materials (BOM)

Displaying Additional Properties in BOMs
You can display Part Name, Specification, and Standard in BOMs.

See Additional Properties for Toolbox Components.

Saving Sort Settings for BOMs
You can save sort settings for BOM tables with the Save current sort settings option
in the Sort dialog box.

The sort settings are saved with the BOM so that you can reapply the saved sort settings
without having to reselect them each time. The saved sort settings are also saved with
the BOM template, which lets you propagate the sorting order across all drawings that
use the same template.

Saving Sort Settings as a BOM Property

To save sort settings:

1. Right-click a BOM table in an assembly or drawing.
2. Set sort criteria for the table.

For example, right-click a table column and click Sort.

3. Under Sort scheme, click Save current sort settings.
4. Click OK.

The current sort settings are saved as a BOM property.
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Saving Sort Settings to a Template

To save sort settings to a template:

1. Right-click the table and click Save As.
2. Navigate to the location where you want to save the template.
3. Type a File name, and for Save as type, select Template (*.sldbomtbt).
4. Click Save.

Using Saved Sort Settings to Create a BOM

To use saved sort settings when you create a BOM:

1. In a drawing or assembly, click Insert > Tables > Bill of Materials.
2. Select a drawing view.
3. For Table Template, select the template for which you saved sort settings.

4. Complete the Bill of Materials PropertyManager and click .
5. Click in the drawing to place the BOM.
6. Right-click in the BOM table and click Sort > Apply Saved Sort Scheme.

Changing a Saved Sort Scheme

To change the sort scheme when a saved sort scheme exists:

1. Right-click a BOM table.
2. Click Sort > Custom Sort.
3. In the Sort dialog box, select new settings.
4. Do one of the following:

• To replace the previously saved settings with your changes, leave Save current
sort settings selected.

• To remove the saved sort scheme from the BOM, clear Save current sort settings.

Dimensions

Aligning Angular Dimensions with Soft Snaps
You can align angular dimensions with soft snaps that match the offsets specified in
Document Properties. You can also drag an angular dimension to align it with adjacent
dimensions using soft snaps.

To specify the offset distances, click Tools > Options > Document Properties >
Dimensions.
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Angular Running Dimensions
Angular running dimensions are a set of dimensions measured from a zero-degree
dimension in a drawing or sketch.

Angular running dimensions meet ISO-129-1: 2004 rules while providing additional styling
options.

Use angular running dimensions for arc or circle models. In this example, you create and
modify angular running dimensions for a flange.

Creating Angular Running Dimensions
You can create angular running dimensions for an arc or circle in a drawing or sketch.

In this example, you create angular running dimensions in a drawing.

To create angular running dimensions:

1. Open install_dir\samples\whatsnew\drawings\angular_running_dimension\
flange.slddrw.
A flange appears.
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2. Save the flange model as my_flange.slddrw.
3. Close install_dir\samples\whatsnew\drawings\angular_running_dimension\

flange.slddrw.

4. Click Angular Running Dimension (Dimensions/Relations toolbar) or Tools >
Dimensions > Angular Running Dimension.

5. In the graphics area, select the center mark of the flange, from which all others will
be measured, to be the base (the zero-degree dimension), and click again to place
the dimension outside the model.
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6. Select the vertices or center marks to dimension. As you select each item, the
dimension is placed in the view, aligned to the zero-degree dimension.

7. Click to exit the angular running dimension mode.

Adding Angular Dimensions Along the Same Running Dimension
You can add more angular dimensions along the same angular running dimension.

In this example, you add more angular running dimensions to the flange.

To add more dimensions along the same angular running dimension:

1. Open my_flange.slddrw, if it is not already open.
2. Right-click an angular running dimension that is on the flange and click Add To

Running Dimension.
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3. Select the vertices or center marks to dimension. As you select each item, the
dimension is placed in the view, aligned to the zero-degree dimension.

4. Click to exit the angular running dimension mode.

Modifying Angular Running Dimensions
You can modify existing angular running dimensions.

In this example, you modify the angular running dimensions on the flange.

To modify angular running dimensions:

1. Open my_flange.slddrw, if it is not already open.
2. In the Dimension PropertyManager on the Leaders tab, make sure Display as chain

dimension is selected.
3. In the graphics area, right-click an angular running dimension that is on the flange

and click Break Alignment.
4. Drag the running dimension chain to move it.

All the running dimensions on the chain move except for the dimension where the
alignment is broken.
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5. Right-click an angular running dimension that is on the flange and click Display
Options, then choose from these options:

DescriptionOption

Aligns all the running dimensions.Align
Running
Dimension
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DescriptionOption

Bends the leader line of a dimension and allows you to reposition the
dimension.

Jog

Applies the automatic jogging to the running dimensions.Re-Jog
Running
Dimension
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DescriptionOption

Adds parentheses around the selected dimension.Show
Parentheses

Shows the selected dimension as an inspection dimension.Show as
Inspection

109

Drawings and Detailing



Displaying Angular Running Dimensions
You can change the display style of existing angular running dimensions.

In this example, you change the display style of the angular running dimensions on the
flange.

To change the display of angular running dimensions:

1. Open my_flange.slddrw, if it is not already open.
2. In the graphics area, right-click an angular running dimension that is on the flange.

In the Dimension PropertyManager on the Leaders tab, choose from these options:

DescriptionOption

Displays angular running dimensions as chain dimensions.Display as
chain
dimension

Causes all angular dimensions to run from the base in the closest
direction. No dimension is greater than 180° from the base.

Run
bidirectionally
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DescriptionOption

Extends the extension line to the center of the dimension set.Extension
line extends
from center
of set
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DescriptionOption

Changes text position for the selected dimension. For example, click

to place the text inline.

Custom Text
Position

3. Close the file without saving it.

Assigning Styles to Dimension Line Elements
You can assign line styles to dimension leaders, dimension lines, and extension lines using
the Dimension PropertyManager.

Automatically Finding Virtual Sharps for Dimensions
While in the dimension tool, you can define virtual sharps between two entities and use
the virtual sharps for dimensioning.

To find virtual sharps:
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1. In the dimension tool, right-click the sketch entity or model geometry, and click Find
Intersection.

2. Select the model geometry or sketch entity that intersects your original selection.

The virtual sharp is found and applied to the active dimension tool.

3. Complete the dimension using the resulting virtual sharp.
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Dimensioning Two Points of the Same Arc
You can add a dimension where both ends are on the same arc, such as in the case of
radii and holes where it is necessary to dimension both quadrants or the center and a
quadrant.

To dimension two points of the same arc:

1. Click Smart Dimension (Dimensions/Relations toolbar) or Tools > Dimensions
> Smart.

2. Shift + select the first quadrant of the arc and select the center or the second
quadrant.

You do not need to hold down the Shift key once you select a quadrant of an arc
to start a dimension.

Highlighting Associated Geometry
In modeling and assembly environments, when you select a reference dimension, the
associated model geometry highlights.

Placing Dimension Text
For ISO Drafting Standard dimensions with solid leader and aligned text, you can use the
Dimension PropertyManager to place text above and below dimension lines, or split
dual-dimension text above and below dimension lines.

You use the Dimension Text field in the PropertyManager to place text. You can split text

only if the Text Position is set to Solid Leader, Aligned Text in Tools > Options
> Document Properties > Dimensions.
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Setting Extension Line to Show Centerline
You can set individual extension lines to display as centerline style. This lets you identify
when an extension line extends from a hole.

To set extension lines to display as centerline style:

Right-click the extension line and click Set Extension Line as Centerline.

Drawing Views

Attaching Existing Annotations to a Different Drawing
View
You can assign existing annotation notes to the current drawing sheet. Within the same
drawing sheet, you can assign existing annotation notes to any drawing view.

To assign an annotation note to a drawing sheet or a drawing view:

1. Right-click the annotation note.
2. Do one of the following:

DescriptionOption

Assign an annotation note to a
drawing sheet.

Click Attachment > Attach to Sheet.

Assign an annotation note to a
drawing view.

Click Attachment > Attach to View, and
select the drawing view to which the
annotation note shall be attached.
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Creating Shaded Drawing Views With High Quality Edges
You can create shaded drawing views with high quality edges to prevent far side edges
from displaying on the near side face of a model. This type of view is appropriate for
thin-walled models with features, such as walls or ribs, that make contact with the back
face of the model.

Also, when you use the high quality option for shaded drawing views, the edges print
with better quality and you can hide the edges.

To create a high quality drawing view with shaded edges:

1. Open install_dir\samples\whatsnew\fundamentals\ThinWallPart.SLDPRT.

2. Click File > Make Drawing from Part.
a) In the Sheet Format/Size dialog box, select A (ANSI) Landscape and click OK.
b) Click Open READ-Only.
c) Click OK.
d) From the View Palette, drag the Isometric view into the drawing.

3. In the PropertyManager, under Display Style, click Shaded With Edges.

Notice that the ribs contacting the back face are visible on the front face.
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4. Click High quality.

The ribs are no longer visible on the front face.

5. Click .

Editing Existing Section Views with Section View Assist
You can use Section View Assist, previously called the Section View User Interface, to
add offsets to existing section views created with Section View Assist in SolidWorks 2013
and later.

Section View Assist is not available for section views whose sketches have been directly
edited.

To edit existing section views with Section View Assist:

1. Right-click on an existing section view or its cutting line and click Edit Cutting Line.

For some complex section views created with SolidWorks 2013, you must select
an insertion point before you can modify them.

2. On the Section view popup, click an offset.

3. Click .

Enhanced Options for View Labels

Auxiliary Views and Drawing Sheet
You can set auxiliary views and section views to be orthographically aligned to the drawing
sheet.

Right-click the drawing view and click Align Drawing View > Horizontal to Sheet
Clockwise or Horizontal to Sheet Counterclockwise.
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After being aligned to sheet clockwiseBefore being aligned to sheet

Tags in View Labels
You can use tags to add content to drawing view labels.

To edit a view label using tags, clear Manual view label in the Note PropertyManager,
right-click the view label and click Edit Text in Window.

The tags within the label display their value as assigned from Document Properties. You
can delete the tags and use the tag buttons or type in your own text.

View Label Font Control
View label font control apply to all view types.

Labels for detail, auxiliary, other and orthographic views have the same font control as
section view does. You can also assign fonts to the individual label elements.

Enhancements to Annotation Views

Annotation View Flat to Screen
An annotation view called Notes Area view is always flat to screen.

In compliance with ASME Y14.41-2003 and other Model Based Definition standards, the

Notes Area annotation view is available on all parts and assemblies. All contents on
Notes Area will be displayed flat to screen and static in relation to each other. When the
model is rotated, all elements on the Annotation View will remain flat to screen at their
position relative to each other.

General Tables in Models and Assemblies
You can insert general tables in models and assemblies.

To insert general tables, click Insert > Tables > General Table.

Tables on Annotation Views
You can assign tables to Annotation Views.

Tables are not forced to be flat to screen. Display of tables are controlled by the annotation
view to which they are assigned. Note: Tables created in documents prior to this release
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are automatically placed on the Notes Area annotation view to continue the previous
behavior.

To assign tables to annotation views, right-click the table, click Change Annotation
View and click a view.

Out-of-Date Drawing Views
You can add annotations and dimensions to out-of-date drawing views and attach these
annotations and dimensions to the model geometry within the out-of-date views. In
addition, out-of-date drawing views are no longer obscured.

This feature saves you a substantial amount of time when you make small changes to
large, out-of-date drawings.

Replace Model for Drawing Views
Use the Replace Model tool to change file references for individual drawing views while
the drawing is open.

You can use the Replace Model tool to change file references between parts and parts,
assemblies and assemblies, and between parts and assemblies. If you create drawings
that have iterative changes or similar parts that require similar dimensioning schemes,
this tool allows you to reuse a drawing in the new context.

In this example, you change file references between simple sheet metal parts and
assemblies.

Replacing Part Reference with Assembly Reference
You can change file references from a part to an assembly.

In this example, you replace a sheet metal part with a sheet metal assembly in a drawing
view. The sheet metal assembly was created by adding one PEM nut to a hole in the sheet
metal part.

Sheet Metal AssemblyPEM NutSheet Metal Part

119

Drawings and Detailing



1. Open install_dir\samples\whatsnew\drawings\replace_model_in_view\
sheet_metal.SLDDRW.
The drawing of a sheet metal part appears.

2. Click Replace Model (Drawing toolbar) or Tools > Replace Model.
3. In the PropertyManager, under Selected Views, click All Views.
4. Under New Model, browse to select install_dir\samples\whatsnew\drawings\

replace_model_in_view\sheet_metal_1_nut.SLDASM and click Open.

5. Click .
The drawing is updated to show one nut added to part, but is otherwise identical to
the drawing of the sheet metal part.
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6. Save the drawing file as sheet_metal_1_nut.SLDDRW.

Replacing Assembly Reference with Assembly Reference
You can change file references from an assembly to an assembly.

In this example, you replace a sheet metal assembly with a new sheet metal assembly
in a drawing view. The new sheet metal assembly was created by adding a second PEM
nut to the second hole in the sheet metal part.

New Sheet Metal AssemblyPEM NutSheet Metal Assembly

1. Open the drawing file that you saved in the previous module,
sheet_metal_1_nut.SLDDRW.
The drawing of the sheet metal assembly with one PEM nut appears.
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2. Click Replace Model (Drawing toolbar) or Tools > Replace Model.
3. In the PropertyManager, under Selected Views, click All Views.
4. Under New Model, browse to select install_dir\samples\whatsnew\drawings\

replace_model_in_view\sheet_metal.SLDASM and click Open.

5. Click .
The drawing is updated to show a second nut added to assembly, but is otherwise
identical to the drawing of the first sheet metal assembly.

6. Save the drawing file as sheet_metal_2_nut.SLDDRW.

Replacing Assembly Reference with Part Reference
You can change file references from an assembly to a part.

In this example, you replace a sheet metal assembly with a sheet metal part in a drawing
view. The sheet metal part was created by removing PEM nuts from the sheet metal
assembly.

Sheet Metal PartPEM NutsSheet Metal Assembly
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1. Open the drawing file that you saved in the previous module,
sheet_metal_2_nut.SLDDRW.
The drawing of the sheet metal assembly with two PEM nuts appears.

2. Click Replace Model (Drawing toolbar) or Tools > Replace Model.
3. In the PropertyManager, under Selected Views, click All Views.
4. Under New Model, browse to select install_dir\samples\whatsnew\drawings\

replace_model_in_view\sheet_metal_1.SLDPRT and click Open.

5. Click .
The drawing is updated to show a sheet metal part with PEM nuts removed, but is
otherwise identical to the drawing of the sheet metal assembly.
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6. Close the drawing without saving it.

Section View of a Surface
You can create a section view of surface bodies from a parent view of a part. Additionally,
you can apply annotations such as notes and dimensions to the cross section of the
surface.

To create a section view of surface bodies:

In a drawing view, click Section View (Drawing toolbar) or Insert > Drawing View
> Section. In the PropertyManager, select Display surface bodies. This setting persists
across sessions.

You can create a section view of surface bodies for legacy drawings if the drawings' parent
views have surface bodies.
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View Palette Shows All Views

View Palette shows drawing views placed on drawings.

After placing a drawing view on a drawing, the view persists in the View Palette and is
identified with a drawing icon. Additionally, the View Palette contains dimetric and trimetric
views.

Other Annotations

Adding Center Marks to Hole Wizard Slots
You can use the Center Mark tool to add center marks for slots created with the Hole
Wizard.

You control how center marks are added for Hole Wizard slots just like you do for slots
created from sketches.

1. Click Options (Standard toolbar) or Tools > Options.
2. On the Document Properties tab, underDrafting Standard, click Centerlines/Center

Marks.
3. Specify the drawing document properties for Center marks, Slot center marks,

and the Center mark layer.
4. Click Detailing, then, under Auto insert on view creation, select Center marks

- slots -part and Center marks -slots -assembly.
5. Click Tables > Hole.
6. Set the Scheme and Tag angle/offset from profile center to use, and click Show

hole centers.
7. Click OK.

8. Click Center Mark (Annotations toolbar) or Insert > Annotations > Center
Mark.

9. In the PropertyManager, select the edge of the slot for which you are inserting the
center mark.

10. Under Auto Insert, select For All Slots and select the Options and Slot center
marks to use.
The location of the center mark is determined by the values used to define the slot
in the Hole Wizard.

11. Click .

125

Drawings and Detailing



Attach Datum Targets to Specific Points
You can dimension and inference datum targets to specific points.

You can use vertex inferences in both drawing and sketch environments to place datum
targets.

While sketching in parts and assemblies, you can use reference dimensions and model
dimensions to control the location of the datum target points. These dimensions are driven
in the model environment and driving in the sketch environment.

When you select a datum target in the graphics area, the geometry it is attached to is
highlighted.

Previously, this functionality was only supported for drawings.
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Displaying Annotation Notes in Uppercase
The All uppercase option displays note text and custom property values in uppercase
letters in drawings, regardless of the case in the note edit field.

You can set the option for individual annotation notes and balloons in the Text Format
section of the Note PropertyManager.

You can also change the default behavior for the current document by displaying the
Options dialog box and selecting All uppercase on the Drafting Standards page of the
Document Properties tab.

Controlling Case for Individual Notes and Balloons
Use the Note PropertyManager to control how the case is displayed for individual notes
and balloons in drawings, models, and assemblies.

1. Click Insert > Annotation > Note.
2. Expand Text Format and click All uppercase.

All alphabetic text in the document is shown in uppercase.

The text appears in uppercase but the actual text value
is not converted. If you edit the text value in the Edit in
Window dialog box or the Custom page of the Properties
dialog box, the text appears as you originally entered it.

To set the text of a
note to display in
uppercase:

1. Double-click the balloon text.
2. In the Note PropertyManager, expand Text Format and
click All uppercase.

To set a balloon
containing text to
display in uppercase:

Select a note or balloon and click Shift + F3.To toggle the All
uppercase setting on
or off:

Setting the Default Case for a Document
Use the Document Properties page of the Options dialog box to set the default case to
use in notes and balloons in the current document.

1. Click Options (Standard toolbar) or Tools > Options.
2. On the Drafting Standard page of the Document Properties tab, under Uppercase,

click All uppercase.
3. To specify strings that should not be automatically capitalized, enter them in the

Exclusion list field, separated by semi-colons (;).
4. Click OK.
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GD&T Feature Control Frame Compliance
The Geometric Tolerance (GD&T) dialog box supports changes specified in the ASME
Y14.5-2009 standards.

Using the Geometric Tolerance dialog box:

• You can combine multiple adjacent rows with the same geometric symbols into a single
composite frame.

• You can insert the symbol for Translation at the end of a selected field.

If you add other symbols, the Translation symbol appears after them in the
field.

JIS Weld Symbols
Six additional JIS weld symbols are available in GTOL.SYM and appear in on the JIS Weld
Symbols page of the Symbol Library dialog box.

Edge

Keyhole

Scarf

Stud

Penetration
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Backing

When you use the JIS drafting standard for weld symbols, the second fillet option is
available for the following symbols:

• Single Bevel Butt
• Single J Butt
• Single Bevel Butt with Root
• Square Butt

The effect is the same as it is for the ISO versions of the Bevel Butt Single symbol.

Slot Callouts
You can use the Hole Callout tool to create callouts for Hole Wizard slots.

The callout format definition file, install_dir\SolidWorks Corp\SolidWorks\lang\
language\calloutformat.txt, has been modified to contain new callouts for each slot
combination. New sections have been added for countersunk, plain, and counterbore
slots.

The slot callouts are at the end of each standard so you can more easily find them if you
want to modify them, or combine them with an already modified calloutformat.txt
file.

You can re-attach the callout leader to the slot at any point along the arc sections of the
slot. The leader always points to the center of the arc. You can control the angle using
the Radial/Diameter leader snap angle. Click Tools > Options > Document
Properties > Dimension to access this option.

The callout displays all slot-related dimensions that are marked for drawing, plus the
THRU-ALL note or depth symbol value if the slot is through or blind.

The slot length is determined by the tangent to tangent length of the main part of the
slot, not the counterbore or countersink tangents.
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Symbol Library Dialog Box
The Symbol Library dialog box has been overhauled for ease of use. Symbols in the dialog
box are categorized by type. You can multiselect symbols and, using the Windows
Character Map, you can select additional symbols to insert.

The Symbol Library is available to add symbols to:

• Dimension text
• Weld symbols
• Geometric tolerances
• Datum Features
• Annotation notes
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To use the Symbol Library to insert symbols into dimension text:

1. Click in a drawing dimension to open the Dimension PropertyManager.
2. On the Value tab, at the bottom of the Dimension Text section, click More.

The Symbols Library dialog box opens. The top section of the Categories list on the
left identifies the categories that contain the symbols that are displayed on the right.

3. Click at the top of the dialog box to pin it open.

You cannot pin the Symbol Library dialog box when you launch it with an annotation
note preview active or from the Weld Symbol dialog box.

4. To add additional symbols to the Symbols display, click another category in the list.
Tooltips provide the symbols' names and tags.

5. Click a symbol to add to the drawing dimension.
It appears in the Symbols to insert field.

You can also add a symbol directly to the drawing dimension by double-clicking it
in the Symbols display.

6. Do one of the following:

• To add the symbol to the dimension immediately, click Apply.

The dialog box remains open so you can select additional symbols.

Apply is only available when the Symbols Library dialog box is pinned.

• Click additional symbols to add them to the Symbols to insert field.

7. To add symbols from the Microsoft Character Map:
a) Click Character Map.
b) In the Character Map, click a symbol and click Select to add it to the Characters

to copy field.
c) When you have added the characters you want, click Copy.
d) Close the Character Map.
e) Paste the characters into the Symbols to insert field.

8. Click OK.

Symbol Library File Location
You can save the symbol library file, GTOL.SYM, in any searchable folder.

If you are administering a network with many users in distributed locations, you can place
a single GTOL.SYM file in a location that all users can access.

Users then specify the location using the File Locations tab of the System Options dialog
box.

To specify a new location for the symbol library file:

1. Click Options (Standard toolbar) or Tools > Options.
2. On the System Options tab, click File Locations.
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3. Under Show folder for, select Symbol Library File.
4. Select the current location of the symbol library file and click Delete.
5. To specify the new location, click Add.
6. In the Browse to dialog box, navigate to the location of GTOL.SYM and click OK.

If the GTOL.SYM file in the new location has different symbol definitions, they are applied
to your drawings.

Symbol in original Symbol Library file location

Symbol in updated Symbol Library file location
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Glass Sheet Crosshatch
Glass sheet crosshatch is available and may be applied to new section views.

Straight Leader Attachment
An annotation note that is surrounded by a triangle border allows straight leaders and
multi-jog leaders to attach to the corners of the border.

Sheet Formats
You can use a second sheet format in drawing templates.

The Drawing Sheets document property lets you specify a default sheet format for when
you add new sheets to drawing documents. This property lets you automatically have
one sheet format for the first sheet and a separate sheet format for all additional sheets.

To specify a different sheet format for a new sheet, click Tools > Options > Document
Properties > Drawing Sheets, select Use different sheet format, and browse to
select a sheet format file (file ending in .slddrt).

Automatically Splitting Tables Horizontally at a Row
You can use the Horizontal Auto Split command to make the SolidWorks software
automatically adjust table rows when you add or remove items from tables.

Supported tables:

• Hole Tables
• Bill of Materials
• General Tables

The automatic splitting of tables applies to the entire table, including portions that appear
on other drawing sheets.

You can specify that the new table segments be placed directly below the last table split
or directly to the right of the last table split:

Before split:
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After split, placed below:

After split, placed to the right:

To set up automatic splitting of a table:

1. Right-click the table and click Split > Horizontal Auto Split.
2. In the dialog box, enter a number in the Maximum number of rows field.
3. Under Apply, select one of the following:

• To apply the Maximum number of rows value to the table once, click This time
only.

• To continuously maintain the automatic splitting of the table, click Continuously

As items are added and removed from the table, it is updated to remain in
compliance with the Maximum number of rows value.

4. Under Placement of new split tables, select one of the following:

• To place the split portions of the table to the right, click Horizontal alignment.
• To place the split portions of the table below, click Vertical alignment.

5. Click Apply.

When Continuously is in effect for a table, to stop automatic splitting, right-click the
table and click Stop Auto Splitting.

Current splits are kept but are no longer adjusted automatically as you make changes to
the table.
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11
eDrawings

eDrawings® Professional is available in SolidWorks Professional and SolidWorks Premium.

This chapter includes the following topics:

• Viewing 3D ContentCentral on iPad
• Viewing DimXpert Dimensions from SolidWorks Part Files
• Viewing Rotational Exploded Steps

Viewing 3D ContentCentral on iPad
You can use eDrawings to view 3D ContentCentral® on an iPad. 3D ContentCentral is a
free service for locating, configuring, downloading, and requesting 2D and 3D parts and
assemblies, 2D blocks, library features, and macros.

Start eDrawings on your iPad, and click http://www.3dcontentcentral.com/.

Viewing DimXpert Dimensions from SolidWorks Part Files
In eDrawings, you can view DimXpert dimensions from files that are saved in SolidWorks
2014 or later.

Viewing Rotational Exploded Steps
In the eDrawings software, you can view rotational exploded steps saved in assembly
files created with SolidWorks 2014 or later.

You can also view exploded steps that rotate a component with or without linear translation
in the eDrawings software.
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12
SolidWorks Electrical

This chapter includes the following topics:

• Replace Microsoft Access with SQLite
• Report Templates for Electrical Calculations
• Support for Mixed Scheme
• Additional Features

Replace Microsoft Access with SQLite
The underlying database management system has been upgraded from Microsoft Access
to SQLite.

This change significantly improves file archival methods.

SQLite is fully compatible with 64 bit operating systems and runs on any version of
Microsoft Office that is installed on the computer.

Report Templates for Electrical Calculations
Using Reporting in SolidWorks Electrical, report templates are available to show common
calculations, like the maximum amp capacity of a wire or cable and the voltage drop
across a length of cable or cable from harness.

You can use the report templates for harnesses, and cables.

Support for Mixed Scheme
SolidWorks Electrical supports a mixed mode for drawing called mixed scheme that allows
you to use schematic tools and line diagram tools in a single environment.

Previously, SolidWorks Electrical only maintained separate drawing types for line diagrams
and for schematics.

Additional Features
The following features are available in this release:
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DescriptionFeature

You can use the Terminal Strips Editor to
sort and renumber selected terminals
according to positioning, marking or
connection criteria.

Sorting and renumbering terminals in the
Terminal Strips Editor

In the Terminal Strips Manager, you can
divide the terminal strip by manually adding
a page break.

Manual page break in terminal strips

When placing a location or function outline,
the objects inside the outline can be
automatically associated with the location
or function.

Location and function outline

A new command allows you to search and
replace text in the interface used to
translate text for projects.

Translation of text for projects

You can manage the maximum number of
connections on a material terminal of a
component, and the use of the terminal.

New data for material terminals of
components

You can edit component material terminals
from the symbol context menu.

Editing component material terminals

You can use a new entity type called
Wipeout to hide entities that are located
behind other entities.

New object used to hide the drawing

The Reports Manager interface has been
significantly improved.

New interface for Reports Manager

The TXT export of project data supports the
.csv format in addition to the TXT format.

Reports, TXT export

You can generate and add data files to the
project.

Reports, TXT and Excel export

You can use filters in the reports templates
sector to search for a template.

Reports templates selector

An index shows the order number of user
data. The index displays in dialog boxes for
electrical objects properties.

User data

A new passive symbol is available. A passive
symbol is not considered as an electrical
symbol. It does not have a mark, circuits
or connection points. It is stored in a library
for insertion into a drawing.

Passive symbol
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DescriptionFeature

You can use more commands, such as
addition, editing and swapping, to manage
the title block.

Drawing contextual menu

You can insert a mask at the same time as
a 2D thumbnail to hide a rail.

2D footprint thumbnails

During unarchiving, you can use a command
in a contextual menu to specify which
objects to keep and which to replace.

Unarchiving

A search function has been added to a side
panel of the components contextual menu.

Component search

In the contextual menu of the cross
references thumbnails, you can access the
cross reference drawing configuration.

Cross references configuration

A new option generates PDF files with the
tree structure for the project in the form of
bookmarks.

PDF export

You can use new criteria in the Project
Manager to reduce the list of projects.

Filters in the Project Manager

When using the Paste Special command, a
dialog box opens allowing you to manage
marks.

Copy and paste special

You can resolve equipotential conflicts
manually with a new command.

Equipotential conflicts

When importing DWG files into the project,
if the DWG file has definitions of symbols
or title blocks, you can launch the wizard to
place title blocks and symbols in the library.

Importing DWG files

A dialog box displays the properties of the
wire, such as marks and technical data, or
all the wires of an equipotential.

Wire properties or equipotential editor

You can use a new type of symbol,
composed mainly of attributes, to display
data specific to the wires and equipotentials.

Wire and equipotential label

The wires display translatable and
non-translatable user data.

User data on the wires

New options are available when inserting a
location outline.

Insertion of a location outline
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13
SolidWorks Enterprise PDM

Available as a separately purchased product that can be used in SolidWorks® Standard,
SolidWorks Professional, or SolidWorks Premium.

This chapter includes the following topics:

• Automated Cache Management
• Consolidated Delayed in State Notifications
• Dynamic Notification Recipients Filter
• Extracting Hidden SolidWorks BOMs
• Flexible "Always work with latest version of files" Option
• Flexible Retrieval of Referenced Files During Check Out
• Increased Workflow Performance
• Navigating Tree Structures
• User Defined Custom Columns
• Version Comparison of Referenced Files
• Version Free Variables and Workflow Transitions
• Visibility of Child Quick Information Warnings in Parent Assemblies

Automated Cache Management
Two options in the User and Group properties dialog boxes let administrators edit user
profiles to set caching behavior. These options automate refreshing and clearing the local
cache on designated folders.

For example, if you store SolidWorks Design Library folders in the vault, to ensure that
users always have the latest version of these files, you can specify that when users log
in, the cache is automatically refreshed for these folders.

The Cache Options page of the user and group properties dialog boxes contains the
following options:

Automatically clears the local cache upon logout. This removes
unneeded files, reduces the cache size, and increases security on
machines used by multiple users.

When users logs out, Enterprise PDM clears the cache of any folders
with this setting using an automated version of the Clear Local Cache
command.

The cache is also cleared when users select to work offline or when
users shut down their computers without logging out.

Clear cache
during logout

139



Ensures that users have the latest version of items like CAD file
templates and standard libraries each time they log in.

When users log in, for every folder with this setting, Enterprise PDM
performs an automated version of the Get Latest command.
Enterprise PDM updates older versions of files in the user's cache and
uploads the latest version of files that are not in the user's cache.

Refresh cache
during login

Administrators can set cache options for individual users or for groups. When users are
part of a group for which cache options have been set, the group settings are reflected
in the users' properties.

Consolidated Delayed in State Notifications
To reduce the number of individual notifications users receive, Enterprise PDM groups all
the delayed in state notifications that occur during the specified time interval and sends
a single email containing the details of the files that meet the delayed in state criteria.

Administrators or users can configure folder notifications to alert users when files in the
folder have been in a workflow state for a specified amount of time. These notifications
are referred to as "delayed in state" notifications.

Previously, separate emails were sent for each file that met the delayed in state criteria.
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To get details of all the files that were identified as delayed in state, users had to open
each notification by clicking Show Next, or by opening each notification in the Inbox.

Now a single notification lists all files that are delayed.
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The Inbox contains that single message.

The notification contains the following information for each file:

Click the link to open the file in the appropriate editor.File Name

Length of time the file has been in the current state.Days in State

Current workflow state.Current State

User who performed the most recent state change.Transition Made By

Opens SolidWorks files in eDrawings. Other files are opened
in the SolidWorks Enterprise PDM File Viewer.

View

Opens the History dialog box for the file associated with the
notification.

History

Opens the folder containing the file in a new Explorer
window.

Open Folder
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Dynamic Notification Recipients Filter
A filter for dynamic notification recipients in the Do Transition dialog box facilitates selection
for users when a company has many users designated for dynamic notification.

This filter is similar to the one in the Workflow editor for adding Role members and
notification recipients.

As users type alpha numeric characters into the Filter field, the results in the recipients
list update dynamically. When users select names from the filter results, those names
remain as they type another filter string.
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Second filter string appliedUser selectedFirst filter string applied

Extracting Hidden SolidWorks BOMs
In the SolidWorks application, you can hide a Bill of Materials on a drawing or assembly
to prevent it from distracting you. Meanwhile, you may want to access the SolidWorks
BOM in Enterprise PDM to export ballooning and other information to other applications
like an MRP/ERP system.

To enable Enterprise PDM to always extract hidden BOMs:

• ClickDisplay>Options > Extract hidden BOM from SolidWorks files on Check-In.

When you check in SolidWorks files with hidden BOMs, the software extracts the BOMs
to Enterprise PDM as SolidWorks BOMs.

Flexible "Always work with latest version of files" Option
Administrators can give users who work in the SolidWorks add-in access to earlier versions
of files even when the Always work with latest version of files setting is enabled.

The Enable the get version command in SolidWorks option lets users access specific
versions of files in the SolidWorks add-in by:

• Expanding the Get flyout in the SolidWorks Enterprise PDM task pane toolbar
• Right-clicking a file in the task pane and clicking Get
• Right-clicking a file in the FeatureManager and clicking Get
• Clicking Enterprise PDM > Get
• Right-clicking a component in the graphics area and clicking Get

This option appears on the Reference Dialog tab of the Settings dialog box when you
select Always work with latest version of files.
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Flexible Retrieval of Referenced Files During Check Out
Administrators can configure user settings to specify how the Check Out dialog box handles
referenced files.

Users typically want to work with the latest version of files. However, some users need
to work with assemblies that use older versions of references that they have cached,
rather than the latest version of the files in the vault.

The revised Reference Dialog page in the user and group Settings dialog box lets
administrators specify whether or not reference files will be automatically selected for
Get latest in the Check Out dialog box. It contains this option, which is the default:

Auto select reference files to get latest when checking out.

To maintain the cached version of reference files during check out, you must clear this
option.

If you enable this option, you can set these conditions:

Retrieves the latest available version of files to the
local vault view when viewing or opening them.

This option was previously available on the Explorer
tab of the Settings dialog box, under
Miscellaneous.

Always work with the latest
version of files.

Only available when you select Always work with
the latest version of files.

Enables the Get Version command in SolidWorks to
retrieve earlier versions of open files.

Enable the Get Version
command in SolidWorks.

Prevents the display of the Check Out dialog box, when
you check out files with references.

The software checks out only the selected files; users
must separately check out each referenced file.

Check out files silently
without showing the check
out dialog box.

When users check out files with references to other
files, the referenced files are also marked for check
out (if it is possible).

If you also activate the option to check out files silently,
checking out parent files automatically checks out all
referenced files.

Try to check out all
referenced files when the
referencing file is checked
out.
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Increased Workflow Performance
The time required for changing workflow states in high latency environments has been
significantly reduced.

The time reduction varies depending on the number of actions you set in the transition
and the amount of latency. The greatest improvement occurs in systems with the highest
latency.

Navigating Tree Structures
The reference tree structures maintained by Enterprise PDM are often large and contain
many levels. New controls in dialog boxes and Preview tabs make it easier to navigate
these structures.

The following navigational aids have been added in Enterprise PDM 2014.

In the Check In, Check Out, Copy Tree, and Change State dialog boxes:

• A Top Level Only / Show All Levels control lets you show just the highest level of
the tree structure or the entire tree structure.

• Expand and collapse arrows within the tree structure let you expand or collapse
individual nodes of the tree.

• Next Warning and Previous Warning arrows in the dialog box toolbars take
you directly to warnings.

• The option to turn on a second set of parent node check boxes at each subassembly
level lets you select or clear all the check boxes for that node.

On the Contains and Where Used tabs:

• Expand and collapse arrows within the tree structure let you expand or collapse
individual nodes of the tree.

User Defined Custom Columns
To facilitate work in dialog boxes and Preview tabs, you can add columns based on
Enterprise PDM variables. You can also rearrange the dialog box display by dragging the
column heads.

For example, if your company organizes documents by part number rather than by file
name, you can add a column that shows the Part Number.

You can add custom columns to the Check In, Check Out, Undo Checkout, and Copy Tree
dialog boxes and to the Contains and Where Used Preview tabs.

To add a custom column to the Check Out dialog box:

1. In Windows Explorer, select the files to check out and click Actions > Check Out.
2. In the dialog box, right-click anywhere in the table headings.

A list of standard headings appears. Check marks indicate which headings are currently
displayed.

3. At the bottom of the list, click More.
4. In the Choose Columns dialog box, scroll to the variable you want to use and select

it.
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5. Click OK.
A new column that uses the variable as its heading appears on the right side of the
dialog box.

6. Click and drag the column to the desired location.

Version Comparison of Referenced Files
In the Enterprise PDM Add-in for SolidWorks, you can set the Task pane display information
to include a Reference version column. This column shows the version of a file that is
referenced by an assembly compared to the latest version of the same file in the database.

Additionally, the quick info icon appears when an assembly references a file version
that is not the latest version in the database.

When you are working with an assembly that contains many subassemblies, this
information can help you decide whether to check out a subassembly and rebuild it so
that it references the latest design version.

Version Free Variables and Workflow Transitions
When you include version free variables in the data card of a file, you can use a workflow
transition to update the content of the variables without creating a new version of the
file.

Administrators must first configure the variables to be version free and then create a
workflow transition that includes actions that set the value of the variables.

When users run the workflow transition by changing the state of a file, the variables'
value update but the file is not versioned unless there are other set variable actions for
non-version free variables.

Visibility of Child Quick Information Warnings in Parent
Assemblies

Child Quick Information warnings in the Enterprise PDM SolidWorks add-in indicate the
status of the in-session SolidWorks file and its references. These icons now appear at the
top assembly level for all lower level files.

Previously, the icons only appeared up one level. You needed to completely expand an
assembly with more than two levels to view the status of lower level files.
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SolidWorks Enterprise PDM 2013

SolidWorks Enterprise PDM 2014
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14
SolidWorks Flow Simulation

SolidWorks Flow Simulation is a Computational Fluid Dynamic (CFD) 3D solution available as
a separately purchased product that can be used with SolidWorks Standard, SolidWorks
Professional, or SolidWorks Premium.

This chapter includes the following topics:

• CircuitWorks and SolidWorks Flow Simulation
• eDrawings Support
• Mesh Control
• Mesh Parallelization
• Parametric Study Mode
• Usability Improvements

CircuitWorks and SolidWorks Flow Simulation
With CircuitWorks, an add-in to SolidWorks Premium, you can create 3D models from
the file formats written by most electrical computer-aided design (ECAD) systems. You
can collaborate to design printed circuit boards (PCBs) that fit and function in SolidWorks
assemblies.

You can import the following CircuitWorks ECAD file PCB or component thermal properties
to SolidWorks Flow Simulation:

• Dielectric and conductor density
• Specific heat
• Conductivity for PCBs
• Conductivity for volumetric heat sources from components

When you conduct thermal analysis with SolidWorks Flow Simulation, the SolidWorks
model references the imported customer thermal properties.

Two options in the Flow Simulation tree facilitate setting up the Computational Fluid
Dynamics (CFD) analysis for cooling simulation of electronic components:

• Right-click Heat Sources and select Import volume source frommodel. Select the
heat sources to import in Item properties.

• Right-click Printed Circuit Boards and select Import Printed Circuit Boards from
model. Select the PCBs to import in Item properties.

149



eDrawings Support
You can export multiple SolidWorks Flow Simulation plots in a single eDrawings file.

Mesh Control
Solution-adaptive meshing is a procedure for adapting the computational mesh to the
solution during the calculation. SolidWorks Flow Simulation extends the solution-adaptive
refinement procedure to local regions of the computational domain for more accurate and
meshed-optimized CFD simulations.
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Mesh Parallelization
SolidWorks Flow Simulation speeds up the meshing task by using multiple cores.

The solver and the mesher can now leverage multi-core processing capability.

Select the number of cores to use for meshing in the Run and Batch Run dialog boxes.

Parametric Study Mode
Parametric Study Mode lets you run multiple fluid flow tests automatically. You can
evaluate the intuitive results to choose the best design.

You can:

• Save studies in the top project tree using the parametric study feature for better
visibility of the CFD simulations and easier investigation of the design scenarios.

• Save selected Design Points into the project tree to save only desired scenarios.
Optionally, you can save the full results of the Design Points.

Usability Improvements
• The Leak Tracker tool is available at the bottom of the graphical screen for better
visibility. You can locate holes or displacement gaps in the model by visualizing the
route from an internal face to an external face of the component.

• You can modify boundary and heat source conditions from a single PropertyManager,
which accelerates the setup of the CFD analysis for large projects.

• You can define goals for surface area and volume with the Equation Goal tool. You
can add surface area and volume as reference geometries into the Equation Goal.
The tool is located in the model View, at the bottom of the graphical area, improving
its visibility.

• You can specify ambient velocity via aerodynamic angles (angle of attack and angle of
sideslip) instead of a 3D vector. This improvement makes it easier to perform a
Parametric study.
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15
Parts and Features

This chapter includes the following topics:

• Conic Fillets
• Extruded Cuts
• Holes
• Mass Properties
• More Options for Deleting Features
• Patterns
• Reference Geometry
• Weldments

Conic Fillets
You can use the Fillet tool to create symmetrical conic shaped fillets for parts, assemblies,
and surfaces.

You can apply conic shapes to Constant Size, Variable Size, and Face fillets.

Creating Constant Size Conic Fillets
In this example, the conic shape you create is a hyperbola.

To create this type of conic fillet:

1. Open install_dir\samples\whatsnew\parts\remote_control.sldprt.

2. Click Fillet/Round (Features toolbar) or Insert > Features > Fillet/Round.
3. In the PropertyManager, under Fillet Type, select Constant size.
4. Select the top face of the model.

Face<1> is added to Items to Fillet.
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Tangent propagation and Full preview are selected.

5. Under Fillet Parameters, type 5mm for Radius.
6. Under Fillet Parameters:

a) Set Radius to 5mm.
b) For Profile, select Conic Rho.

c) Set Rho Radius to 0.65 degrees.

Rotate the model to view the curvature of the fillets. Use the callouts in the graphics
area to change values for Radius and Conic Rho. The shape of the fillets adjust
dynamically.

7. Click .

Extruded Cuts
You can create extruded cuts in both directions with one click.

In the Cut-Extrude PropertyManager, select Through All - Both Directions. Direction
2 automatically updates with the same value.

Previously, you had to specify Through All for each direction separately.
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Holes

Creating Slots from the Hole Wizard
You can create counterbored, countersunk, and straight slots from the Hole Wizard.

To create a Hole Wizard slot for a part:

1. Select a face and click Hole Wizard (Features toolbar) or Insert > Features >
Hole > Wizard.

2. In the PropertyManager, on the Type tab, for Hole Type, select a slot type:

DescriptionOption

Counterbore Slot

Countersink Slot

Straight Slot

3. Under Hole Specifications, for Slot length , enter a value.

4. Select other options and click .

You can also create Hole Wizard or hole series slots in assemblies.

Displaying Decimal Values for Drill Hole Sizes
When specifying straight hole or slot sizes, you can display decimal hole sizes for letter,
number, or fractional drill sizes.

You can display decimal sizes for straight holes or slots in the Hole Wizard Type
PropertyManager, or the Hole Series (First Part) PropertyManager.

To open the Hole Wizard Type PropertyManager from a part, click Hole Wizard
(Features toolbar) or Insert > Features > Hole > Wizard.

To open the Hole Wizard Type PropertyManager from an assembly, click Hole Wizard

(Features toolbar) or Insert > Assembly Feature > Hole > Wizard.
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To open the Hole Series (First Part) PropertyManager, from an assembly, click Hole

Series (Features toolbar) or Insert > Assembly Feature > Hole > Hole Series.

To display decimal values for hole sizes from either PropertyManager:

1. Select a straight hole or slot:

• In the Hole Wizard Type PropertyManager, for Hole Type, select Hole or

Slot .
• In the Hole Series (First Part) PropertyManager, for Start Hole Specification,

select Hole or Slot .

2. For Standard, select one of the following:

• ANSI Inch
• DME
• PCS
• Progressive
• Superior.

3. For Type, select one of the following:

• All Drill Sizes
• Letter Drill Sizes
• Fractional Drill Sizes
• Number Drill Sizes

4. Set other options and click .

Mass Properties

Volumetric Units
Volumetric units, such as gallons, liters, cubic yards, and cubic decimeters, are supported
by Mass Properties.

More Options for Deleting Features
When you delete a parent feature that has child or absorbed features, you can select
which features to delete.

The Advanced Confirm Delete dialog box lets you selectively delete child and absorbed
features. The features that you retain might display warnings or error messages in the
FeatureManager design tree. You must manually resolve any errors.
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Deleting Absorbed and Child Features

To delete absorbed and child features in a model:

1. Open install_dir\samples\whatsnew\parts\arm.sldprt.

2. In the FeatureManager design tree, right-click Cut-Extrude2 and select Delete .

The Confirm Delete dialog box appears in Basic mode and lists all dependent items
related to Cut-Extrude2. You cannot delete items individually in Basic mode.

3. Click Advanced.

The dialog updates from Basic to Advanced mode. This mode lets you select which
items to keep and which to delete.

4. Click to clear Fillet2.

Mirror1, Sketch7, and Cut-Extrude4 are selected for deletion.

5. Click Yes.

A warning displays for Fillet2. You can ignore the error or repair the model before
continuing with your work.

Patterns

Highlight Seed Feature
To identify a seed feature in a pattern more easily, click the pattern in the FeatureManager
design tree. The seed highlights in a different color from the pattern instances.

Pattern instances are highlighted in Selected Item 1 color, and seeds in Selected Item
2 color. You can change these colors by clicking Tools > Options > Colors.

Display Tooltips with Pattern Information
You can display a tooltip about a pattern.

When you set this system option, information displays when you hover over the pattern
name in the FeatureManager design tree.

Information about the pattern includes:
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• Pattern name
• Pattern type
• All seeds used to create the pattern
• Spacing and number of instances for Direction 1 and Direction 2
• Instances skipped
• Instances varied

Click Tools > Options. On the System Options tab, click Display/Selection and select
or clear Display pattern information tooltips.

Multibody Support for Pattern and Mirror Features
When pattern or mirror features split single bodies into multiple bodies, you can select
which bodies to keep using the Bodies to Keep dialog box.

You can also specify which configurations to keep up to date.

Previously, the SolidWorks software randomly selected bodies to keep.

Reference Geometry

Inferenced Reference Points
The Point PropertyManager has additional items for creating reference points.

You can create reference points at the intersections of the following entities:

• An axis and a plane
• An axis and a surface, both planar and non-planar
• Two axes

You can use the On Point option to add reference points on a sketch point and on the
end of a sketch section.

Plane Alignment
When creating a plane using a line and a plane or a face, the SolidWorks software aligns
the X-axis of the new plane with the line.

This ability delivers a more predictable orientation when sketching on new planes, and
corrects inconsistencies in previous versions.

Reference Plane Normal

The Flip Normal option in the Plane PropertyManager lets you flip the normal vector
of a manually created reference plane.

An indicator arrow displays the direction of the normal vector in the graphics area. The
option does not apply to default reference planes.

This function is available as a command. You can access the Flip Normal command
from a context toolbar or Edit menu.
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You can set also the command as a mouse gesture from Tools > Customize > Mouse
Gestures > Edit > Flip normal.

Weldments

Propagate Cut List Properties
The workflow has improved for propagating cut list properties to a new part. You can use
the Insert Into New Part command to copy cut list properties to the file level or the
cut list level.

The Save Bodies, Insert Part, and Insert Mirror Part commands have this same
capability, which helps with designing multibody parts.

Right-click the Cut List Properties folder in the FeatureManager design tree and click
Insert Into New Part.

Structural Members as Library Features
You can configure multiple weldment profiles of structural members as library features.

You can add different configurations of a structural member and save them as one profile
in a library feature.

For example, instead of having 50 separate library feature files for square tubing sizes,
you can have one library feature file with 50 configurations that you can control by a
design table.

When creating or editing structural members, you can select the configured library features
in the Structural Member PropertyManager.
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16
SolidWorks Plastics

SolidWorks Plastics Professional and SolidWorks Plastics Premium are available as separately
purchased products that you can use in SolidWorks Standard, SolidWorks Professional, or
SolidWorks Premium.

This chapter includes the following topics:

• Getting Started Wizard
• Help Updates for Dynamic Advisor
• Injection Location
• Machine Details
• Mold Layout Wizard
• Runner Design Wizard Gate Descriptions

Getting Started Wizard
The Getting Started Wizard guides you through the SolidWorks Plastics workflow. It guides
you through the process of creating a meshed model, selecting a plastics material,
specifying process parameters such as mold and melt temperature plus injection time
and pressure, and running an analysis.

The Getting Started Wizard also helps you view and interpret the results, and access the
Dynamic Adviser for problem-solving advice and creating reports.

To access the Getting Started Wizard, click SolidWorks Plastics > Getting Started
Wizard.

The Getting Started Wizard is available in SolidWorks Plastics Professional and
SolidWorks Plastics Premium.

Help Updates for Dynamic Advisor
The Dynamic Advisor help has been modified to contain the most up-to-date information.

Injection Location
Gate Selection has been renamed to Injection Location.

To more accurately reflect the specific action you perform with this command, Gate
Selection has been renamed to Injection Location. You can specify an injection location
at a location other than a gate, for example, at the beginning of a sprue. The functionality
does not necessarily involve or create actual gate geometry.
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Machine Details
You can access machine details in the Fill Settings PropertyManager.

Modifications in the Fill Settings PropertyManager:

• Flow Settings has been renamed to Fill Settings.
• The PropertyManager includes the Maximum Injection Pressure option.
• You are no longer required to select or specify an injection molding machine during
the analysis setup workflow. Instead, in the PropertyManager, you can specify the
maximum injection pressure limit.

• You can access the machine database under Advanced.

Mold Layout Wizard
The Mold Layout Wizard guides you through creating and analyzing single-cavity,
multi-cavity, and family mold layouts. The Mold Layout Wizard helps you create feed
system components, such as sprues, runners, and gates. It also shows you how to
automatically balance family mold runner systems.

To access the Mold Layout Wizard, click SolidWorks Plastics > Mold Layout Wizard

The Mold Layout Wizard is available in SolidWorks Plastics Premium only.

Runner Design Wizard Gate Descriptions
The following gates have been renamed to reflect generally accepted industry terminology.

New Gate NamePrevious Gate Name

Edge GateSide

Submarine GateSubmarine

Banana GateHorn
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17
Routing

Available in SolidWorks Premium.

This chapter includes the following topics:

• Display Colored Connector Pins
• Edit Connector Tables
• Electrical Flattening Enhancements
• Enhancements to Routing Library Manager
• O-let Improvements
• Slope Improvements
• Spool Enhancements
• Support for Assembly Connectors in From-To Lists
• Support for Crimps and Terminals in Connector Library

Display Colored Connector Pins
To help you connect wires to pins, wire pins for flattened routes are colored when they
display in connector blocks. The pin colors match the color of the wires used in the 3D
Route. These pin colors are also listed in the connector tables.

Edit Connector Tables
A BOM-based connector table is available using the .sldbomtbt file extension. BOM-based
connector tables preserve edits through model updates.

You can also save your connector tables as templates. Column selection, column order,
and customized headers are stored in templates for re-use. You can still create earlier
versions of connector tables using the .sldtbt templates.

BOM-based connector tables can also display additional details about the pin connections
if they are present in the model. For example, terminals, seals, and plugs are available
in Column Properties.

Previously, updates to the model would undo any text added to the connector tables.
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Electrical Flattening Enhancements
Enhancements for electrical flattening include the ability to:

• Route with loops. Loop segments display in dotted lines for annotation and
manufacturing flattened routes.

• Support coverings and clips.
• Modify the connector locations and orientations of flat routes. By rotating connectors,
you can place the desired connector face on top in flattened drawings.

• Adjust multi-pin connector fan-out length.
• Adjust the formboard size for manufacturing flattened routes.
• Select items to display for flattened route drawings. The items include balloons, clips,
cable lengths, connector tables, coverings, wire balloons, circuit summary and electrical
BOMs.

Enhancements to Routing Library Manager
The Routing Library Manager supports assembly fittings for piping and tubing, and
assembly connectors for electrical routing. You can use the Routing Component Wizard
to ensure that your assembly fittings and connectors have the necessary requirements
for use in route assemblies.

Previously, the Routing Component Wizard supported only parts.

O-let Improvements
Using a sketch dimension, you can set a dimension to an o-let stub to locate it with a
linear dimension or orient it with an angular dimension.

Existing o-lets which are mated in place will continue to solve until you delete and re-insert
them.

Slope Improvements
Improvements for slopes include the ability to drag fittings and to add multiple route
segments to existing sloped routes.

You can also add weld gaps to segments contained in the slope.

To add a slope to a pipe route, open a routing assembly and click Piping > Edit Route

. Right-click the sketch entity at the location where you want to add the slope and

select Add Slope .
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Spool Enhancements
You have more flexibility when creating spools. You can define spools using the following
components:

• non-continuous or disjoint route segments
• components mated to end fittings
• hangers and supports
• pipes with penetration points

Previously, you could only create spools with route segments and fittings that were
contiguous.

To define spools in a routing assembly, Routing > Piping > Define Spools .

Support for Assembly Connectors in From-To Lists
You can use assembly connectors in From-To Lists. The details about the assembly
connectors display in connector tables and BOMs.

Support for Crimps and Terminals in Connector Library
You can pre-define terminals, seals, and miscellaneous components using the
components.xml and .xls files.

This additional information is automatically added to wire and cable connections while
creating electrical routes.

You can also define terminals, seals, and miscellaneous components for each wire and
cable connection in the Edit Wires PropertyManager.

The details of these components display in BOMs.

A sample library of these components is also provided with the Routing Library and is
named InterconnectAndAccessoriesLibrary.xml.
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18
Sheet Metal

This chapter includes the following topics:

• Adding Sheet Metal Gussets
• Bent Lofted Bends
• Corner Reliefs and Bend Transitions
• Swept Flanges for Conical and Cylindrical Bodies

Adding Sheet Metal Gussets
You can create sheet metal gussets with specific indents that go across bends.

To add sheet metal gussets:

1. Click Sheet Metal Gusset (Sheet Metal toolbar) or Insert > Sheet Metal >
Sheet Metal Gusset.

2. In the Sheet Metal Gusset PropertyManager, under Position, select:

• The bend face or two planar faces that are adjacent to a bend.
• The edge to be used as a reference.

This can be any linear entity in order to specify the alignment of the gusset.

• The point to be used for dimensioning.

If you pick the edge you automatically get an endpoint as a reference. However,
you can also choose another entity, such as a sketch point or an endpoint of a line.

To move the gusset in relation to the selected point, check Offset and specify the
offset amount.

3. Under Profile:
a) Do one of the following:

• For a gusset that is symmetrical relative to the bend face, select Indent depth
and specify a depth.

• For an asymmetrical gusset, select Profile dimensions.

Either specify the depth (d1) of one gusset leg and specify an angle (a1) or
specify the depth of each gusset leg.
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To reverse the lengths of the legs, click Flip dimension sides.

b) Select a gusset type:

GussetPreviewButtonOption

Rounded rib

Flat rib

c) If you choose Flat rib, optionally, specify an Edge Fillet.

4. Under Dimensions:
a) Enter a value for Indent width to specify the width of the gusset.
b) Enter a value for Indent thickness to specify the gusset wall thickness.

c) To specify an angle for the gusset sides, click and enter a value for Side face
draft.

d) Optionally, change the values for Inner corner fillet and Outer corner

fillet . You can also disable the buttons to remove fillets.

5. Under Preview, select one of the following:

Full previewPartial preview
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6. Click .

Bent Lofted Bends
You can create a bent lofted bend to create physical bends, rather than formed geometry
and approximated bend lines in a flat pattern. Bent lofted bends form a realistic transition
between two parallel profiles to facilitate instructions for press brake manufacturing.

To create a bent lofted bend:

1. Open install_dir\samples\whatsnew\sheetmetal\lofted_bends.SLDPRT.

2. Click Lofted Bends (Sheet Metal toolbar) or Insert > Sheet Metal > Lofted
Bends.

3. Under Manufacturing Method, select Bent.
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4. Select both profiles at the open points shown.

The preview appears:

5. Under Faceting Options, select Number of bends to specify the number of bends
for each segment between a vertex and the related portion of the arc.
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6. Under Facet Value, type 5 for the Facet Value.

7. Select Refer to endpoint to calculate the transition between segments at the sharp
corner.

8. Under Sheet Metal Parameters, select Override default parameters, in
Thickness, type 1.0, and in Bend Radius, type 1.0.

9. Under Bend Allowance, select K-Factor, and type 0.5.
10. Under Auto Relief, select Rectangular, select Use relief ratio, and in Ratio, type

0.5.

11. Click .

Corner Reliefs and Bend Transitions
You can apply corner treatments to a folded sheet metal body that will persist in the
flattened state. You can view how the corner treatment impacts the folded sheet metal
body and how it carries over to the flat pattern.

You can use any of the following corner treatment types:

Rectangular
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Circular

Tear

Obround

Constant
Width

You can create configuration-specific corner reliefs and suppress or unsuppress them
within configurations. For example, for configuration A, you can define a corner relief by
selecting all corners and applying a circular relief. In configuration B, you can select all
corners and apply a rectangular relief that is suppressed in configuration A and vice versa.

Adding a Corner Relief
You can add a corner relief to a single sheet metal body.

1. Click Corner Relief (Sheet Metal toolbar) or Insert > Sheet Metal > Corner
Relief.

2. In the Corner Relief PropertyManager, under Scope, select the sheet metal body to
which to apply the corner relief.

3. Under Corners, click Collect all corners to list all corners in the sheet metal body.
If you list multiple corners, you can specify multiple corner relief treatments.

When you select a corner in the Corners section, the faces that define the corner
are shown in the Define Corner section and the corner is highlighted in the graphics
area.

4. To add an individual corner instead of collecting all corners, in the Define Corner
section, select the faces that define the corner and click New Corner.
The corner is added to the list in the Corners section.

5. With a corner selected, under Relief Options, select the type of relief to apply.
The relief type determines other options you can specify:
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Constant WidthObroundTearCircularRectangularAvailable options

NAYesNAYesYesCentered on bend
lines

NAYesNAYesYesSlot Length

YesYesYesYesYesRatio to thickness

NANANAYesYesTangent to bend

NANANANAYesAdd filleted
corners

NANANANAYesCorner Fillets

NAYesNAYesNASlot Width

NAYesNAYesYesNarrow corner

Previews of your choices appear in the graphics area.

6. Click .

7. Click Flatten (Sheet Metal toolbar) to see how the corner relief appears in the
flattened sheet metal part.

Swept Flanges for Conical and Cylindrical Bodies
The Cylindrical/Conical Bodies section of the Swept Flange PropertyManager lets you
select a linear sketch entity that propagates to the flat pattern as a fixed entity.

The Cylindrical/Conical Bodies option is only available when the selected path along
which the profile sweeps is a sketch.

With the Swept Flange tool, you can use composite sketch contours that are swept along
a circular path. When you select a linear sketch entity to propagate, the software can
correctly flatten cylindrical or conical shapes that include features such as rolled ribs or
flanges that have been added as seams.

To specify a cylindrical flat pattern, you select a sketch entity that is horizontal or vertical
with respect to the sweep path. To specify a conical flat pattern, you select a slanted
sketch entity.

Without the Cylindrical/Conical Bodies option, when you flatten a conical body, the
flattened shape is a rectangle.
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Flattened without using the Cylindrical/Conical Bodies
option

Conical shape

When you use the Cylindrical/Conical Bodies option to select a slanted sketch entity,
the flattened pattern is conical.

Resulting conical flattened patternSlanted sketch entity
selected

Creating a Conical Body with a Swept Flange
When you add a swept flange to a conical sheet metal body, you can use the
Cylindrical/Conical Bodies section to ensure that the resulting body flattens correctly.

The Cylindrical/Conical Bodies option is only available when the selected path along
which the profile sweeps is a sketch.
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1. Click Swept Flange (Sheet Metal toolbar) or Insert > Sheet Metal > Swept
Flange.

2. Select the profile and path for the swept flange feature.

PathProfile

3. Expand Cylindrical/Conical Bodies and click the check box to enable the option.
4. Select a linear sketch segment that is part of the profile to act as a fixed entity when

you unfold the part.
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5. Click .

6. Click Flatten (Sheet Metal toolbar) to see the resulting flat pattern.
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19
SolidWorks Simulation

SolidWorks Simulation Professional and SolidWorks Simulation Premium are available as
separately purchased products that can be used with SolidWorks Standard, SolidWorks
Professional, or SolidWorks Premium.

The linear static analysis capability is available in SolidWorks Premium.

This chapter includes the following topics:

• Connectors
• Contact
• Materials
• Performance
• Post-Processing
• Importing Results from SolidWorks Plastics

Connectors

Automatic Conversion of Toolbox Fasteners to Bolts
You can automatically convert Toolbox fasteners in models to Simulation bolt connectors.

Available for SolidWorks Simulation Professional and above.

To run the automatic detection tool, in the Study PropertyManager, under Options, select
Convert Toolbox fasteners to bolt connectors (may take time).

This tool is available for linear static, nonlinear static, and nonlinear dynamic studies.

During the conversion process, all information related to the location, geometric features,
and material of the Toolbox fasteners is mapped internally to the formulation of the
corresponding bolt connectors.
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In the Connector (Bolt) PropertyManager these fields are populated during conversion:

All geometric entities are populated for these type of connectors:Type

Standard or Counterbore with Nut

Countersink with Nut

Standard or Counterbore Screw

Countersink Screw

If the Toolbox fastener has material assigned, then the same material is used
for the bolt connector definition. Otherwise, the default material Alloy Steel
is used.

Material

ISO Bolt threads: At = 0.7854 * [d - (0.9382 / n)]
2, where

d is given in mm, and n is given in threads/mm.

ANSI threads: At = 0.7854 * [d - (0.9743 / n)]
2, where d

is given in inches, and n is given in threads/inch.

D = nominal diameter of bolt (from the Toolbox Fastener
data), and n is number of threads per inch (mm) (from the
Toolbox Fastener data)

Reference: Machinery's Handbook published by Industrial
Press.

Tensile stress
area

Equals the Yield Strength of the fastener’s material.Bolt Strength

Strength
data
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FI = 0.75 x At x 0.20 Yield Strength

Reference: Machinery's Handbook published by Industrial Press, 27th Edition
– pg. 1495.

Pre-load

You can view the Simulation bolt connectors that were created under Connectors .

Bolt connectors share the naming convention of their Toolbox counterparts that have the
same size and length. Bolt connectors of the same size are grouped into a subfolder. The
Toolbox components excluded from the analysis are listed in Auto-Converted Toolbox
Fasteners under Parts.

• Review and verify the properties of the converted connectors before you proceed
with the analysis.

• You still need to define a contact condition (no-penetration in most cases) to prevent
interference between bodies fastened by the Toolbox fasteners.

• Toolbox items such as gears and pins are not automatically converted to Simulation
connectors.

Listing Connector Output Forces
For spring, spot weld, and link connectors, you can list the output forces after you run a
static or nonlinear analysis.

Right-click Results and click List Connector Force.

The List Pin/Bearing Force option is removed. Listing of output forces for all
connectors is available from the Result Force/Connector force PropertyManager.

You can list the results for all connectors in the current study, or filter the results for
selected connectors only. Available selections are:

• All spot welds
• All links
• All bearings
• Individual connectors

• All connectors
• All pins
• All bolts
• All springs

When you select a row in the table, the corresponding connector highlights in the graphics
area and a callout lists all forces.
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Press Shift to select multiple, consecutive rows. Press Ctrl to select multiple, individual
rows.

To export all connectors' forces to a Microsoft Excel spreadsheet, click Save to file .

Contact

Contact Pressure Plots in 2D Simplification
You can view contact pressure plots in linear and nonlinear 2D Simplification studies.

Available for SolidWorks Simulation Professional and above.

In the Stress Plot PropertyManager, under Component , select CP: Contact Pressure.

Contact pressure is developed in areas where two bodies come into contact during the
analysis and no penetration contact is defined. To enhance the visibility of areas that
come into contact and their view is obstructed, an option to show the contact pressure
plot only on selected entities is available.

In the Stress Plot PropertyManager, under Advanced Options, select Show plot only
on selected bodies. Select the faces to show the contact pressures.

You can view the contact pressures in 2D plots as vectors, and also in 3D plots. In the
Stress Plot PropertyManager, under Display, select Show as 3D plot or Show as vector
plot.

For 3D plots, the results are extruded across the section depth as defined in the properties
of the study (plane stress, plane strain), or revolved about the axis of symmetry
(axi-symmetric studies).
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Contact Visualization Plot
With a new contact visualization plot, you can inspect all the contacts created in the
model.

Available for SolidWorks Simulation Professional and above.

A contact visualization plot allows you to detect easily the different types of contact in
your model applied with global, component, or contact set definitions.

Right-click Connections and click Contact Visualization Plot .

The regions of the model where contact is defined are rendered in a color unique to each
contact type. The types of contact supported are:

Color RenderingContact Type

RedBonded

PurpleNo Penetration

GreenAllow penetration (Free
contact)

OrangeShrink Fit

YellowVirtual Wall

PurpleThermal Contact
Resistance

GreenInsulated
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In the Contact Visualization Plot PropertyManager click Calculate to view the
geometry-based contact pairs. The geometry-based contacts include all geometric entities
(edges, faces or bodies) that are initially touching (before starting the analysis) and have
a contact definition assigned automatically or manually.

To view at the mesh element level the areas of the model detected by the solver (before
starting the analysis) with an assigned contact definition, select Include solver generated
contacts (mesh required).

Under Results, select Show solver-based contacts. The Contact Visualization Plot
renders the mesh elements that belong to the geometric entities of the model with assigned
contact definitions.

Plot of solver-based no penetration contact.
Rendering of mesh elements that participate

in contact formulation.

Plot of geometry-based no-penetration
contact. Rendering of the touching edge

between the two components.

Materials
SolidWorks Simulation Professional and SolidWorks Simulation Premium users with active
SolidWorks Simulation subscription services can access a much larger library of materials
via the online SolidWorks materials portal.

Available for SolidWorks Simulation Professional and above.

An extended material database is provided through a partnership with Matereality LLC.

You can search for materials based on the type of simulation study you want to perform,
or the material model you want to use. Materials downloaded from the online SolidWorks
materials portal are automatically added to the materials list available in the SolidWorks
Simulation Material dialog box.

Performance
Performance improvements include the reduced solution time and better convergence of
results for certain nonlinear studies, the reduced time for initial loading of Simulation
studies, and the availability of a new direct sparse solver for large problems.

Enhancements for nonlinear studies include:
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• Better convergence for node-to-surface no-penetration contact formulation with overall
performance improvement for up to 30%.

• Improved accuracy of results for shells with plasticity material models when using small
displacement formulation.

Initial Loading of Simulation Studies
The time for performing initial loading of models with Simulation studies is reduced. The
performance improvement is more prominent for models with multiple Simulation studies.

A new option Load all Simulation studies when opening a model (requires more
time to open a model) is available under System Options.

Select this option to save all the information for Simulation studies to the memory upon
opening a model. It might take longer time to open models with multiple Simulation
studies.

If you clear this option, only the basic information for each Simulation study is saved to
the memory upon opening a model. When you activate a study, the rest of the Simulation
study data is saved to the memory.

Large Problem Direct Sparse
A direct solver is available that leverages multicore processing capability and improves
solution speed for static and nonlinear studies.

In the Static or Nonlinear dialog box, under Solver, select Large Problem Direct Sparse.

By leveraging enhanced memory-allocation algorithms, the solver can handle simulation
problems that exceed the physical memory of your computer.

If you initially select the Direct Sparse solver and due to limited memory resources it
has reached an out-of-core solution, a warning message alerts you to switch to the Large
Problem Direct Sparse.

Post-Processing
User interface enhancements:

• Common access to Edit Definition, Chart Options, and Settings PropertyManagers.
• Ability to edit the min and max values on plot legends. Click the min or max value of
the plot legend and type a new value.

• Quick access to the Fringe Options of the plot. Right-click anywhere on the plot legend
boundary and click Fringe Options.

• Ability to quickly change the display state of mesh on result plots. Right-click anywhere
on the plot legend boundary and select or clear Show Mesh.

Mirrored Results About Planes of Symmetry
For models where you apply planar symmetry or cyclic symmetry restraints to leverage
the geometric and loading symmetry conditions, you can view results on the full model.
The display of results on the full model, instead of only a section of the model, gives you
better insight on the model behavior and helps you identify potential modeling errors.

In the PropertyManager of the desired result quantity, under Advanced Options, select
Display symmetric results.
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The results are mirrored about the planes of symmetry for models where you analyze
half, a quarter, or one-eighth of the actual geometry. For circular symmetry, results are
repeated cyclically about the defined axis of revolution.

For circular symmetry, the angle between the selected faces must be evenly divisible
into 360. The axis of symmetry must lie at the intersection of the two selected planes
where you apply the cyclic symmetry.

The new option for displaying results on the full model is available for stress, displacement,
strain, design insight, and factor of safety plots and for all study types that support the
planar and cyclic symmetry restraints.

You can save the plots that display the results on the full model to eDrawings files. The
load symbols, mesh, and restraint symbols applied to the model are visible only to the
geometry sections that are analyzed, and they are not mirrored about the planes of
symmetry.

Results shown on the full model geometry
One quarter of the pressure vessel is

analyzed by applying symmetry restraints
to a set of orthogonal faces

Results Comparison Across Configurations
With the Compare Results tool, you can compare up to four result plots from Simulation
studies that are associated with different configurations of the same model.

This cross-configuration comparison mode gives you full control over the display of results
by using existing configuration functionality.

To access this PropertyManager, click Compare Results (Simulation
CommandManager).

Under Options, select All studies in all configurations (slower) to compare up to
four result plots from studies associated with different configurations.

For plots of the same type, you can select the plot which controls the settings.
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Second Configuration - First Mode ShapeDefault Configuration - First Mode Shape

Second Configuration - Second Mode ShapeDefault Configuration - Second Mode Shape

Importing Results from SolidWorks Plastics
For plastic parts, you can import temperatures and in-mold residual stresses from
SolidWorks Plastics Premium in a nonlinear static study.

Available for SolidWorks Simulation Premium.

By simulating the cooling down process from temperatures sustained during the injection
molding process to room temperature, you can calculate the final residual stresses and
displacements of the plastic part.

You can only import data from SolidWorks Plastics Premium for a single part that
meshes with solid elements.
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After you run the packing process (Flow + Pack) in SolidWorks Plastics Premium, you can
export the in-mold residual stresses and temperature data to a file (*.POE) in a binary
format that can be read by Simulation. The binary file stores:

• Node coordinates and element connectivity of the original mesh
• Nodal values for temperature and in-mold residual stresses (three normal and three
shear stress components)

• Material properties

You import the data stored in the binary file (*.POE) in a Simulation nonlinear static study
to calculate the final displacements of the part.

Simulation applies a time curve from time t = 0 sec to t = 1 sec to the nodal temperatures
to cool uniformly the part to room temperature (298 Kelvin). Shrinkage of the part may
occur during the cooling process.

Simulation adds the in-mold residual stress components (at pseudo time t = 0 sec) and
the quenching thermal stress components (at time t = 1 sec) to calculate the final results.

You cannot control how long it will take to cool the part, since time in nonlinear static
studies is pseudo time.

Importing InjectionMolding Data fromSolidWorks Plastics
In this example, you import from SolidWorks Plastics the residual stresses and
temperatures generated after the packing phase in a Simulation nonlinear study. You
calculate the final stresses and displacements of a plastic cup after it cools down to room
temperature.

To open the model, go to:

install_dir\samples\whatsnew\plastics\cup.sldprt.

Review the Ready Study features:

• Imported in-mold stresses
• Material definition stored in the Custom Materials folder
• Mesh properties
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Importing Injection Molding Data
You create a nonlinear study and import the in-mold residual stresses and temperatures
at the end of the packing phase from SolidWorks Plastics.

1. Create a nonlinear static study with a name In-mold stresses.
2. Right-click the new study folder and click Properties.
3. In the In-mold stresses tab:

a) Select Import in-mold stresses from SolidWorks Plastics.
b) For File name, browse to location install_dir\samples\whatsnew\plastics
and select inmold_stresses.POE.
The file *.POE contains stress and temperature nodal data calculated after the
packing process in SolidWorks Plastics. The file is in binary format and you cannot
edit it.

The option Include material from SolidWorks Plastics is selected by default,
because the material has been assigned for the part in SolidWorks Plastics. To apply
different material properties, clear this option and apply a material from the SolidWorks
Material database.

4. Click OK.

A new icon In-mold stresses appears under External Loads .

The nonlinear solver applies the imported in-mold stresses and nodal temperatures
from the end of packing phase at time t = 0.

To simulate the cooling process, it associates internally the in-mold temperature data
with a time curve decreasing from the initial values at time t = 0 to a room
temperature (298 Kelvin) at pseudo time t = 1.0.

Meshing and Running the study
You mesh the part and run the nonlinear study.

1. Mesh the model using the Standard mesh and the default meshing settings.
2. Run the nonlinear study.

The solver maps internally the nodal and element connectivity information stored in
the *.POE file to the new mesh created in Simulation.

You do not have to add fixtures to run the analysis. The nonlinear solver internally
applies soft springs to stabilize the part and resolve stiffness singularities.

Viewing Results after Cooling
After the analysis completes, you can plot the final residual stresses and displacements
of the part after it is completely cooled.

The final shape of the part (at pseudo time t = 1 sec) considers the effect of both the
in-mold stresses (at pseudo time t = 0) and quenching thermal stresses.

To view the final shape of the part:

1. Under Results, open the Displacement Plot PropertyManager.
2. Set Time to 1 sec and select Automatic under Deformed Shape.
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3. In the Settings tab, select Superimpose model on the deformed shape.
4. Click OK.
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20
Sketching

This chapter includes the following topics:

• Automatic Tangency for Conics
• Maintaining Proportions in a Sketch Profile
• Path Length Dimension
• Replace Sketch Entities
• Sketch Equations
• Sketch Picture Scale Tool
• Splines
• Using Stick Fonts

Automatic Tangency for Conics
Auto Tangency accelerates the process of sketching a conic curve.

When you select this option in the Conic PropertyManager, you set the first and second

endpoints for the conic curve. The Conic tool applies tangent relations at each endpoint
of the curve and selects the top vertex of the curve. This option is helpful when you
reference existing geometry.

If you clear this option, you must define the top vertex of the curve.

Maintaining Proportions in a Sketch Profile
When you specify the first dimension in a sketch for parts or assemblies, all entities in
the sketch profile automatically scale uniformly based on the dimension.

This functionality helps maintain the proportions of a sketch profile and only applies when
you add the very first dimension to a sketch. Angular and scalar dimensions are not
supported.

Path Length Dimension
You can set a path length dimension to a chain of sketch entities. You can set the
dimension to be a driving dimension, so that when you drag the entities, the path length
resizes consistently.

The path length dimension can help constrain belt and chain assemblies or pulley systems.
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You can reference this dimension in custom properties, configurations, equations, or
tables, including design tables and BOMs.

Click Tools > Dimensions > Path Length or right-click the sketch and click Dimensions

> Path Length .

Replace Sketch Entities
The Replace Sketch Entity command lets you replace one sketch entity with another
without breaking downstream references (unless the downstream reference requires a
different type of geometry, such as mates). For example, if you replace a line with a
spline, downstream features that reference faces created by that spline, will rebuild
successfully.

When you delete one sketch entity and replace it, you often need to create a new set of
references. If you use the Replace Sketch Entity command instead, the new entity
inherits references from the old one and you don’t need to recreate them. During the
replacement, you can also change inherited references and add new ones.

You can replace only one entity at a time.

To access the Replace Sketch Entity command:

• Right-click a sketch entity and click Replace Entity.
• Right-click a sketch entity and click Delete. In the Sketcher Confirm Delete dialog box,
click Replace Entity.

• Click Tools > Sketch Tools > Replace .
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Example for Replace Sketch Entity
In this example, you replace an arc with a spline.

To replace a sketch entity:

1. Open install_dir\samples\whatsnew\sketching\replace_entity.sldprt.

2. In the FeatureManager design tree, select Boss-Extrude2 and right-click Edit Sketch

.
3. In the graphics area, use the rotate and zoom tools to view the sketch as needed and

select the spline near the top edge of the sketch.

4. In the pop-up toolbar, click Construction Geometry .

This command converts Spline1 from construction geometry to a solid curve.

5. Select the arc and in the pop-up toolbar, click Replace Entity .

The Replace PropertyManager lists Arc2 as the entity to replace.

6. In the PropertyManager, click Make Construction.
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7. In the graphics area, select Spline1.

8. Right-click and close the sketch.

The model automatically rebuilds.

Spline1, the new sketch entity, maintains all the dimensions and relations that had been
defined for Arc2.

Sketch Equations
You can specify sketch dimensions using equations instead of discrete values. The
equations solve automatically as you drag the sketch geometry.

To use equations to specify dimensions, double-click a dimension in a sketch and in the
Modify dialog box, start the equation by typing = (equal sign). You can also enter a
Global Variable, Function, or File Property from the flyout menu.

Sketch equations are listed in the Sketch View of the Equations, Global Variables,
and Dimensions dialog box. Click Tools > Equations to display the dialog box.

You can also edit sketch equations in the Equations dialog box to create custom constraints.

Sketch Picture Scale Tool
The Sketch Picture tool provides a scale tool that lets you easily and accurately position
bitmap images in sketch planes and scale them to fit.

Click Tools > Sketch Tools > Sketch Picture .
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Splines

Setting a Fixed Length
You can set a dimension to fix the length of a spline. You can reference this dimension
in custom properties, configurations, equations, and tables, including design tables and
BOMs.

Previously, you could not dimension splines to a fixed length.

To set a fixed length:

1. Open install_dir\samples\whatsnew\sketching\fixed_length.sldprt.

2. Click Smart Dimension (Dimensions/Relations toolbar) or Tools > Dimensions
> Smart Dimensions.

3. Click anywhere on the spline to place the dimension and click to close the
Dimension PropertyManager.

A radial style dimension appears and is attached to the spline.

4. Drag an endpoint of the spline.
The length remains the same when you drag endpoints or change the shape of the
spline.

5. To change the spline's length, double-click the dimension and enter a new value in
the Modify dialog box.

Style Splines

Use the Style Spline tool to sketch single-span Bézier curves. These curves let you
create smooth and robust surfaces, and are available in 2D and 3D sketches.

The style spline consists of only one span. You shape its curvature by selecting and
dragging control vertex points. Sketch entities connect the control vertices which form
the control polygon of the curve.
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With style splines, you can easily control the degree and continuity of the curves. You
can inference style splines for tangency or equal curvature. You can constrain the points
and dimension the curves' sides. These curves also support mirroring and self-symmetry.

You can access the Style Spline tool from Style Spline (Sketch toolbar) or Tools >
Sketch Entities > Style Spline.

Sketching a Style Spline
You can sketch a style spline as a bridge curve between two existing entities.

To sketch the style spline:

1. Open a new sketch. Use the Centerpoint Arc tool to sketch two arc entities.

2. Click Style Spline (Sketch toolbar) or Tools > Sketch Entities > Style Spline.
3. In the graphics area, click the first endpoint of the arc.

The first click creates the first control vertex point in the style spline.
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4. Hover the pointer over the inference line and click to add a second control vertex
point as shown.

If you snap the second control vertex to the inference line, a tangent relation is
created at that endpoint.

5. Continue moving the pointer to the right and hover over the next inference line. Click
the pointer when the equal curvature icon appears.

If you snap the third control vertex to the inference line, an equal curvature relation
is created at that endpoint.
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6. To complete the style spline, continue adding more control vertices. When you reach
the endpoint of the second arc, press ALT + double-click the pointer at the endpoint.

Pressing ALT applies automatic tangent relations at the last control vertex point.

The bridge curve between the two sketch entities is complete.
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Inserting a Control Vertex
The Insert Control Vertex command adds one or more control vertices to style splines.
Each control vertex you add increases the curve's degree.

Control vertices are similar to spline points. They help you manage the shape of the curve.
You can add dimensions between control vertices and add relations.

To insert a control vertex:

1. In an open sketch, right click anywhere on the control polygon and select Insert

Control Vertex .

The pointer changes to .

2. Hover the pointer over the control polygon segment where you want to place the
control vertex and click to insert the point.

The control polygon splits the segment at the new control vertex and the curvature adjusts
accordingly.
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Constraining a Style Spline
You can constrain a style spline by dimensioning line segments in the control polygon.

To constrain line segments in a control polygon:

1. In an open sketch, click Smart Dimension (Dimensions/Relations toolbar) or Tools
> Dimensions > Smart.

2. Click a line segment in the control polygon.

3. Move the pointer to show the dimension preview.

4. Set the value in the Modify dialog box and click .

You can continue to place more dimensions, such as angular dimensions.
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Using Local Edit
Local edit allows you to drag and manipulate the shape of a style spline without affecting
adjacent style splines. This setting is helpful when you are working with multiple style
splines that are connected but not fully constrained.

To modify a style spline using Local edit:

1. In an open sketch, select the style spline you wish to edit locally only.

Local edit only works with two or more style splines.

The Style Spline PropertyManager displays.

2. In the Style Spline PropertyManager, under Options, select Local edit.
3. In the graphics area, select and drag a control vertex.

You can manipulate the shape of the control polygon without affecting the shape of
the other style spline that it is attached to.

4. Click .

Using Stick Fonts
You can use stick fonts when applying sketch text to parts or assemblies for laser
engraving, water jet, and for Computer Numerical Control (CNC) machining.

Stick fonts are also called single line, stroke, or open loop fonts. Use the OLFSimpleSansOC
Regular font for all stick fonts.

To use stick fonts:

1. Click Tools > Sketch Entities > Text.
2. In the PropertyManager, under Text, clear Use document font.
3. Click Font.
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4. In the Choose Font dialog box, under Font, select the OLF SimpleSansOC font.
5. Select any other options, and click OK.
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